{"id":"CVE-2021-34625","state":"PUBLISHED","title":"WP Upload Restriction <= 2.2.3 - Authenticated Stored Cross-Site Scripting","description":"A vulnerability in the saveCustomType function of the WP Upload Restriction WordPress plugin allows low-level authenticated users to inject arbitrary web scripts. This issue affects versions 2.2.3 and prior.","publishedAt":"2021-07-07T12:21:38.493Z","updatedAt":"2024-09-16T18:56:07.715Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["WP Upload Restriction WP Upload Restriction"],"affected":[{"vendor":"WP Upload Restriction","product":"WP Upload Restriction","versions":[{"version":"2.2.3","status":"affected","lessThanOrEqual":"2.2.3","versionType":"custom"}]}],"references":["https://www.wordfence.com/vulnerability-advisories/#CVE-2021-34625"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:48:38.863Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/34xxx/CVE-2021-34625.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-34625","state":"PUBLISHED","datePublished":"2021-07-07T12:21:38.493Z","dateUpdated":"2024-09-16T18:56:07.715Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2021-06-10T00:00:00.000Z"},"containers":{"cna":{"title":"WP Upload Restriction <= 2.2.3 - Authenticated Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"A vulnerability in the saveCustomType function of the WP Upload Restriction WordPress plugin allows low-level authenticated users to inject arbitrary web scripts. This issue affects versions 2.2.3 and prior."}],"affected":[{"vendor":"WP Upload Restriction","product":"WP Upload Restriction","versions":[{"version":"2.2.3","status":"affected","lessThanOrEqual":"2.2.3","versionType":"custom"}]}],"references":[{"url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-34625","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":6.4,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"LOW","scope":"CHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","dateUpdated":"2021-07-07T12:21:38.000Z","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599"},"credits":[{"lang":"en","value":"Angelo Righi"}],"datePublic":"2021-07-02T00:00:00.000Z","solutions":[{"lang":"en","value":"Uninstall plugin from WordPress site."}],"source":{"discovery":"EXTERNAL"},"x_generator":{"engine":"Vulnogram 0.0.9"},"x_legacyV4Record":{"CVE_data_meta":{"AKA":"Wordfence","ASSIGNER":"security@wordfence.com","DATE_PUBLIC":"2021-07-02T15:05:00.000Z","ID":"CVE-2021-34625","STATE":"PUBLIC","TITLE":"WP Upload Restriction <= 2.2.3 - Authenticated Stored Cross-Site Scripting"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"WP Upload Restriction","version":{"version_data":[{"version_affected":"<=","version_name":"2.2.3","version_value":"2.2.3"}]}}]},"vendor_name":"WP Upload Restriction"}]}},"credit":[{"lang":"eng","value":"Angelo Righi"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"A vulnerability in the saveCustomType function of the WP Upload Restriction WordPress plugin allows low-level authenticated users to inject arbitrary web scripts. This issue affects versions 2.2.3 and prior."}]},"generator":{"engine":"Vulnogram 0.0.9"},"impact":{"cvss":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":6.4,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"LOW","scope":"CHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-34625","refsource":"MISC","url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-34625"}]},"solution":[{"lang":"en","value":"Uninstall plugin from WordPress site."}],"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-34625","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-04T00:19:47.621Z"}}]}}}