{"id":"CVE-2021-32782","state":"PUBLISHED","title":"Cross-Site Scripting in Nextcloud Circles","description":"Nextcloud Circles is an open source social network built for the nextcloud ecosystem. In affected versions the Nextcloud Circles application is vulnerable to a stored Cross-Site Scripting (XSS) vulnerability. Due the strict Content-Security-Policy shipped with Nextcloud, this issue is not exploitable on modern browsers supporting Content-Security-Policy. It is recommended that the Nextcloud Circles application is upgraded to 0.21.3, 0.20.10 or 0.19.14 to resolve this issue. As a workaround users may use a browser that has support for Content-Security-Policy. A notable exemption is Internet Explorer which does not support CSP properly.","publishedAt":"2021-09-07T20:00:19.000Z","updatedAt":"2024-08-03T23:33:55.634Z","severity":{"score":5.8,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:N","source":"GitHub_M"},"assigner":"GitHub_M","products":["nextcloud security-advisories"],"affected":[{"vendor":"nextcloud","product":"security-advisories","versions":[{"version":"< 0.19.1","status":"affected"},{"version":">= 0.20.0, < 0.20.10","status":"affected"},{"version":">= 0.21.0, < 0.21.3","status":"affected"}]}],"references":["https://github.com/nextcloud/security-advisories/security/advisories/GHSA-hgpq-28gj-jrj9","https://github.com/nextcloud/circles/commit/dbb97a83ccb342c839a54f088aa19b8ba6844b0e","https://hackerone.com/reports/1217606"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:48:33.225Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/32xxx/CVE-2021-32782.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-32782","state":"PUBLISHED","datePublished":"2021-09-07T20:00:19.000Z","dateUpdated":"2024-08-03T23:33:55.634Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2021-05-12T00:00:00.000Z"},"containers":{"cna":{"title":"Cross-Site Scripting in Nextcloud Circles","descriptions":[{"lang":"en","value":"Nextcloud Circles is an open source social network built for the nextcloud ecosystem. In affected versions the Nextcloud Circles application is vulnerable to a stored Cross-Site Scripting (XSS) vulnerability. Due the strict Content-Security-Policy shipped with Nextcloud, this issue is not exploitable on modern browsers supporting Content-Security-Policy. It is recommended that the Nextcloud Circles application is upgraded to 0.21.3, 0.20.10 or 0.19.14 to resolve this issue. As a workaround users may use a browser that has support for Content-Security-Policy. A notable exemption is Internet Explorer which does not support CSP properly."}],"affected":[{"vendor":"nextcloud","product":"security-advisories","versions":[{"version":"< 0.19.1","status":"affected"},{"version":">= 0.20.0, < 0.20.10","status":"affected"},{"version":">= 0.21.0, < 0.21.3","status":"affected"}]}],"references":[{"url":"https://github.com/nextcloud/security-advisories/security/advisories/GHSA-hgpq-28gj-jrj9","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/nextcloud/circles/commit/dbb97a83ccb342c839a54f088aa19b8ba6844b0e","tags":["x_refsource_MISC"]},{"url":"https://hackerone.com/reports/1217606","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"HIGH","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":5.8,"baseSeverity":"MEDIUM","confidentialityImpact":"HIGH","integrityImpact":"NONE","privilegesRequired":"LOW","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","dateUpdated":"2021-09-07T20:00:19.000Z","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa"},"source":{"advisory":"GHSA-hgpq-28gj-jrj9","discovery":"UNKNOWN"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"security-advisories@github.com","ID":"CVE-2021-32782","STATE":"PUBLIC","TITLE":"Cross-Site Scripting in Nextcloud Circles"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"security-advisories","version":{"version_data":[{"version_value":"< 0.19.1"},{"version_value":">= 0.20.0, < 0.20.10"},{"version_value":">= 0.21.0, < 0.21.3"}]}}]},"vendor_name":"nextcloud"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Nextcloud Circles is an open source social network built for the nextcloud ecosystem. In affected versions the Nextcloud Circles application is vulnerable to a stored Cross-Site Scripting (XSS) vulnerability. Due the strict Content-Security-Policy shipped with Nextcloud, this issue is not exploitable on modern browsers supporting Content-Security-Policy. It is recommended that the Nextcloud Circles application is upgraded to 0.21.3, 0.20.10 or 0.19.14 to resolve this issue. As a workaround users may use a browser that has support for Content-Security-Policy. A notable exemption is Internet Explorer which does not support CSP properly."}]},"impact":{"cvss":{"attackComplexity":"HIGH","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":5.8,"baseSeverity":"MEDIUM","confidentialityImpact":"HIGH","integrityImpact":"NONE","privilegesRequired":"LOW","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:N","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')"}]}]},"references":{"reference_data":[{"name":"https://github.com/nextcloud/security-advisories/security/advisories/GHSA-hgpq-28gj-jrj9","refsource":"CONFIRM","url":"https://github.com/nextcloud/security-advisories/security/advisories/GHSA-hgpq-28gj-jrj9"},{"name":"https://github.com/nextcloud/circles/commit/dbb97a83ccb342c839a54f088aa19b8ba6844b0e","refsource":"MISC","url":"https://github.com/nextcloud/circles/commit/dbb97a83ccb342c839a54f088aa19b8ba6844b0e"},{"name":"https://hackerone.com/reports/1217606","refsource":"MISC","url":"https://hackerone.com/reports/1217606"}]},"source":{"advisory":"GHSA-hgpq-28gj-jrj9","discovery":"UNKNOWN"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/nextcloud/security-advisories/security/advisories/GHSA-hgpq-28gj-jrj9","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://github.com/nextcloud/circles/commit/dbb97a83ccb342c839a54f088aa19b8ba6844b0e","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://hackerone.com/reports/1217606","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T23:33:55.634Z"}}]}}}