{"id":"CVE-2021-32702","state":"PUBLISHED","title":"Reflected XSS from the callback handler's error query parameter","description":"The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions before and including `1.4.1` are vulnerable to reflected XSS. An attacker can execute arbitrary code by providing an XSS payload in the `error` query parameter which is then processed by the callback handler as an error message. You are affected by this vulnerability if you are using `@auth0/nextjs-auth0` version `1.4.1` or lower **unless** you are using custom error handling that does not return the error message in an HTML response. Upgrade to version `1.4.1` to resolve. The fix adds basic HTML escaping to the error message and it should not impact your users.","publishedAt":"2021-06-25T16:25:11.000Z","updatedAt":"2024-08-03T23:25:31.131Z","severity":{"score":8,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N","source":"GitHub_M"},"assigner":"GitHub_M","products":["auth0 nextjs-auth0"],"affected":[{"vendor":"auth0","product":"nextjs-auth0","versions":[{"version":"< 1.4.2","status":"affected"}]}],"references":["https://github.com/auth0/nextjs-auth0/security/advisories/GHSA-954c-jjx6-cxv7","https://github.com/auth0/nextjs-auth0/commit/6996e2528ceed98627caa28abafbc09e90163ccf","https://www.npmjs.com/package/%40auth0/nextjs-auth0"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:48:33.225Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/32xxx/CVE-2021-32702.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-32702","state":"PUBLISHED","datePublished":"2021-06-25T16:25:11.000Z","dateUpdated":"2024-08-03T23:25:31.131Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2021-05-12T00:00:00.000Z"},"containers":{"cna":{"title":"Reflected XSS from the callback handler's error query parameter","descriptions":[{"lang":"en","value":"The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions before and including `1.4.1` are vulnerable to reflected XSS. An attacker can execute arbitrary code by providing an XSS payload in the `error` query parameter which is then processed by the callback handler as an error message. You are affected by this vulnerability if you are using `@auth0/nextjs-auth0` version `1.4.1` or lower **unless** you are using custom error handling that does not return the error message in an HTML response. Upgrade to version `1.4.1` to resolve. The fix adds basic HTML escaping to the error message and it should not impact your users."}],"affected":[{"vendor":"auth0","product":"nextjs-auth0","versions":[{"version":"< 1.4.2","status":"affected"}]}],"references":[{"url":"https://github.com/auth0/nextjs-auth0/security/advisories/GHSA-954c-jjx6-cxv7","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/auth0/nextjs-auth0/commit/6996e2528ceed98627caa28abafbc09e90163ccf","tags":["x_refsource_MISC"]},{"url":"https://www.npmjs.com/package/%40auth0/nextjs-auth0","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"HIGH","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":8,"baseSeverity":"HIGH","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"NONE","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","dateUpdated":"2021-06-25T16:25:10.000Z","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa"},"source":{"advisory":"GHSA-954c-jjx6-cxv7","discovery":"UNKNOWN"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"security-advisories@github.com","ID":"CVE-2021-32702","STATE":"PUBLIC","TITLE":"Reflected XSS from the callback handler's error query parameter"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"nextjs-auth0","version":{"version_data":[{"version_value":"< 1.4.2"}]}}]},"vendor_name":"auth0"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions before and including `1.4.1` are vulnerable to reflected XSS. An attacker can execute arbitrary code by providing an XSS payload in the `error` query parameter which is then processed by the callback handler as an error message. You are affected by this vulnerability if you are using `@auth0/nextjs-auth0` version `1.4.1` or lower **unless** you are using custom error handling that does not return the error message in an HTML response. Upgrade to version `1.4.1` to resolve. The fix adds basic HTML escaping to the error message and it should not impact your users."}]},"impact":{"cvss":{"attackComplexity":"HIGH","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":8,"baseSeverity":"HIGH","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"NONE","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')"}]}]},"references":{"reference_data":[{"name":"https://github.com/auth0/nextjs-auth0/security/advisories/GHSA-954c-jjx6-cxv7","refsource":"CONFIRM","url":"https://github.com/auth0/nextjs-auth0/security/advisories/GHSA-954c-jjx6-cxv7"},{"name":"https://github.com/auth0/nextjs-auth0/commit/6996e2528ceed98627caa28abafbc09e90163ccf","refsource":"MISC","url":"https://github.com/auth0/nextjs-auth0/commit/6996e2528ceed98627caa28abafbc09e90163ccf"},{"name":"https://www.npmjs.com/package/@auth0/nextjs-auth0","refsource":"MISC","url":"https://www.npmjs.com/package/@auth0/nextjs-auth0"}]},"source":{"advisory":"GHSA-954c-jjx6-cxv7","discovery":"UNKNOWN"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/auth0/nextjs-auth0/security/advisories/GHSA-954c-jjx6-cxv7","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://github.com/auth0/nextjs-auth0/commit/6996e2528ceed98627caa28abafbc09e90163ccf","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://www.npmjs.com/package/%40auth0/nextjs-auth0","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T23:25:31.131Z"}}]}}}