{"id":"CVE-2021-28567","state":"PUBLISHED","title":"Magento Commerce improper authorization allows an authenticated user to perform certain functions without permission","description":"Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are vulnerable to an Improper Authorization vulnerability in the customers module. Successful exploitation could allow a low-privileged user to modify customer data. Access to the admin console is required for successful exploitation.","publishedAt":"2021-09-08T16:19:57.701Z","updatedAt":"2024-09-17T02:26:51.638Z","severity":{"score":5,"label":"Medium","version":"3.0","vector":"CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L","source":"adobe"},"assigner":"adobe","products":["Adobe Magento Commerce"],"affected":[{"vendor":"Adobe","product":"Magento Commerce","versions":[{"version":"unspecified","status":"affected","lessThanOrEqual":"2.4.2","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"2.3.6-p1","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"2.4.1-p1","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"None","versionType":"custom"}]}],"references":["https://helpx.adobe.com/security/products/magento/apsb21-30.html"],"weaknesses":["CWE-285"],"ingestedAt":"2026-10-29T19:48:19.096Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/28xxx/CVE-2021-28567.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-28567","state":"PUBLISHED","datePublished":"2021-09-08T16:19:57.701Z","dateUpdated":"2024-09-17T02:26:51.638Z","assignerShortName":"adobe","assignerOrgId":"078d4453-3bcd-4900-85e6-15281da43538","dateReserved":"2021-03-16T00:00:00.000Z"},"containers":{"cna":{"title":"Magento Commerce improper authorization allows an authenticated user to perform certain functions without permission","descriptions":[{"lang":"en","value":"Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are vulnerable to an Improper Authorization vulnerability in the customers module. Successful exploitation could allow a low-privileged user to modify customer data. Access to the admin console is required for successful exploitation."}],"affected":[{"vendor":"Adobe","product":"Magento Commerce","versions":[{"version":"unspecified","status":"affected","lessThanOrEqual":"2.4.2","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"2.3.6-p1","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"2.4.1-p1","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"None","versionType":"custom"}]}],"references":[{"url":"https://helpx.adobe.com/security/products/magento/apsb21-30.html","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_0":{"attackComplexity":"HIGH","attackVector":"NETWORK","availabilityImpact":"LOW","baseScore":5,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"LOW","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.0"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-285","description":"Improper Authorization (CWE-285)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"adobe","dateUpdated":"2021-09-08T16:19:57.000Z","orgId":"078d4453-3bcd-4900-85e6-15281da43538"},"datePublic":"2021-05-11T00:00:00.000Z","source":{"discovery":"EXTERNAL"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"psirt@adobe.com","DATE_PUBLIC":"2021-05-11T23:00:00.000Z","ID":"CVE-2021-28567","STATE":"PUBLIC","TITLE":"Magento Commerce improper authorization allows an authenticated user to perform certain functions without permission"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Magento Commerce","version":{"version_data":[{"version_affected":"<=","version_value":"2.4.2"},{"version_affected":"<=","version_value":"2.3.6-p1"},{"version_affected":"<=","version_value":"2.4.1-p1"},{"version_affected":"<=","version_value":"None"}]}}]},"vendor_name":"Adobe"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are vulnerable to an Improper Authorization vulnerability in the customers module. Successful exploitation could allow a low-privileged user to modify customer data. Access to the admin console is required for successful exploitation."}]},"impact":{"cvss":{"attackComplexity":"None","attackVector":"None","availabilityImpact":"None","baseScore":5,"baseSeverity":"Medium","confidentialityImpact":"None","integrityImpact":"None","privilegesRequired":"None","scope":"None","userInteraction":"None","vectorString":"CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"Improper Authorization (CWE-285)"}]}]},"references":{"reference_data":[{"name":"https://helpx.adobe.com/security/products/magento/apsb21-30.html","refsource":"MISC","url":"https://helpx.adobe.com/security/products/magento/apsb21-30.html"}]},"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://helpx.adobe.com/security/products/magento/apsb21-30.html","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T21:47:32.570Z"}}]}}}