{"id":"CVE-2021-28556","state":"PUBLISHED","title":"Magento Commerce DOM-based cross-site scripting (XSS) could lead to arbitrary javascript execution","description":"Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are affected by a DOM-based Cross-Site Scripting vulnerability on mage-messages cookies. Successful exploitation could lead to arbitrary JavaScript execution by an unauthenticated attacker. User interaction is required for successful exploitation.","publishedAt":"2021-06-28T13:42:13.145Z","updatedAt":"2024-09-17T02:11:10.307Z","severity":{"score":6.9,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:L/A:N","source":"adobe"},"assigner":"adobe","products":["Adobe Magento Commerce"],"affected":[{"vendor":"Adobe","product":"Magento Commerce","versions":[{"version":"unspecified","status":"affected","lessThanOrEqual":"2.4.2","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"2.3.6-p1","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"2.4.1-p1","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"None","versionType":"custom"}]}],"references":["https://helpx.adobe.com/security/products/magento/apsb21-30.html"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:48:19.096Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/28xxx/CVE-2021-28556.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-28556","state":"PUBLISHED","datePublished":"2021-06-28T13:42:13.145Z","dateUpdated":"2024-09-17T02:11:10.307Z","assignerShortName":"adobe","assignerOrgId":"078d4453-3bcd-4900-85e6-15281da43538","dateReserved":"2021-03-16T00:00:00.000Z"},"containers":{"cna":{"title":"Magento Commerce DOM-based cross-site scripting (XSS) could lead to arbitrary javascript execution","descriptions":[{"lang":"en","value":"Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are affected by a DOM-based Cross-Site Scripting vulnerability on mage-messages cookies. Successful exploitation could lead to arbitrary JavaScript execution by an unauthenticated attacker. User interaction is required for successful exploitation."}],"affected":[{"vendor":"Adobe","product":"Magento Commerce","versions":[{"version":"unspecified","status":"affected","lessThanOrEqual":"2.4.2","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"2.3.6-p1","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"2.4.1-p1","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"None","versionType":"custom"}]}],"references":[{"url":"https://helpx.adobe.com/security/products/magento/apsb21-30.html","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":6.9,"baseSeverity":"MEDIUM","confidentialityImpact":"HIGH","integrityImpact":"LOW","privilegesRequired":"HIGH","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:L/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"Cross-site Scripting (DOM-based XSS) (CWE-79)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"adobe","dateUpdated":"2021-06-28T13:42:13.000Z","orgId":"078d4453-3bcd-4900-85e6-15281da43538"},"datePublic":"2021-05-11T00:00:00.000Z","source":{"discovery":"EXTERNAL"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"psirt@adobe.com","DATE_PUBLIC":"2021-05-11T23:00:00.000Z","ID":"CVE-2021-28556","STATE":"PUBLIC","TITLE":"Magento Commerce DOM-based cross-site scripting (XSS) could lead to arbitrary javascript execution"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Magento Commerce","version":{"version_data":[{"version_affected":"<=","version_value":"2.4.2"},{"version_affected":"<=","version_value":"2.3.6-p1"},{"version_affected":"<=","version_value":"2.4.1-p1"},{"version_affected":"<=","version_value":"None"}]}}]},"vendor_name":"Adobe"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are affected by a DOM-based Cross-Site Scripting vulnerability on mage-messages cookies. Successful exploitation could lead to arbitrary JavaScript execution by an unauthenticated attacker. User interaction is required for successful exploitation."}]},"impact":{"cvss":{"attackComplexity":"None","attackVector":"None","availabilityImpact":"None","baseScore":6.9,"baseSeverity":"Medium","confidentialityImpact":"None","integrityImpact":"None","privilegesRequired":"None","scope":"None","userInteraction":"None","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:L/A:N","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"Cross-site Scripting (DOM-based XSS) (CWE-79)"}]}]},"references":{"reference_data":[{"name":"https://helpx.adobe.com/security/products/magento/apsb21-30.html","refsource":"MISC","url":"https://helpx.adobe.com/security/products/magento/apsb21-30.html"}]},"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://helpx.adobe.com/security/products/magento/apsb21-30.html","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T21:47:32.667Z"}}]}}}