{"id":"CVE-2021-26073","state":"PUBLISHED","title":"Broken Authentication in Atlassian Connect Express (ACE) from version 3.0.2 before version 6.6.0: Atlassian Connect Express is a Node.js package for building Atlassian Connect apps","description":"Broken Authentication in Atlassian Connect Express (ACE) from version 3.0.2 before version 6.6.0: Atlassian Connect Express is a Node.js package for building Atlassian Connect apps. Authentication between Atlassian products and the Atlassian Connect Express app occurs with a server-to-server JWT or a context JWT. Atlassian Connect Express versions from 3.0.2 before 6.6.0 erroneously accept context JWTs in lifecycle endpoints (such as installation) where only server-to-server JWTs should be accepted, permitting an attacker to send authenticated re-installation events to an app.","publishedAt":"2021-04-16T03:00:19.147Z","updatedAt":"2025-02-12T20:46:54.554Z","severity":{"score":7.7,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N","source":"CISA-ADP"},"assigner":"atlassian","products":["Atlassian Atlassian Connect Express (ACE)"],"affected":[{"vendor":"Atlassian","product":"Atlassian Connect Express (ACE)","versions":[{"version":"3.0.2","status":"affected","lessThan":"unspecified","versionType":"custom"},{"version":"unspecified","status":"affected","lessThan":"6.6.0","versionType":"custom"}]}],"references":["https://confluence.atlassian.com/pages/viewpage.action?pageId=1051986099","https://community.developer.atlassian.com/t/action-required-atlassian-connect-vulnerability-a%5B%E2%80%A6%5Dypass-of-app-qsh-verification-via-context-jwts/47072","https://security.netapp.com/advisory/ntap-20210604-0004/"],"weaknesses":["CWE-287"],"ingestedAt":"2026-10-29T19:48:13.210Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/26xxx/CVE-2021-26073.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-26073","state":"PUBLISHED","datePublished":"2021-04-16T03:00:19.147Z","dateUpdated":"2025-02-12T20:46:54.554Z","assignerShortName":"atlassian","assignerOrgId":"f08a6ab8-ed46-4c22-8884-d911ccfe3c66","dateReserved":"2021-01-25T00:00:00.000Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"Broken Authentication in Atlassian Connect Express (ACE) from version 3.0.2 before version 6.6.0: Atlassian Connect Express is a Node.js package for building Atlassian Connect apps. Authentication between Atlassian products and the Atlassian Connect Express app occurs with a server-to-server JWT or a context JWT. Atlassian Connect Express versions from 3.0.2 before 6.6.0 erroneously accept context JWTs in lifecycle endpoints (such as installation) where only server-to-server JWTs should be accepted, permitting an attacker to send authenticated re-installation events to an app."}],"affected":[{"vendor":"Atlassian","product":"Atlassian Connect Express (ACE)","versions":[{"version":"3.0.2","status":"affected","lessThan":"unspecified","versionType":"custom"},{"version":"unspecified","status":"affected","lessThan":"6.6.0","versionType":"custom"}]}],"references":[{"url":"https://confluence.atlassian.com/pages/viewpage.action?pageId=1051986099","tags":["x_refsource_MISC"]},{"url":"https://community.developer.atlassian.com/t/action-required-atlassian-connect-vulnerability-a%5B%E2%80%A6%5Dypass-of-app-qsh-verification-via-context-jwts/47072","tags":["x_refsource_MISC"]},{"url":"https://security.netapp.com/advisory/ntap-20210604-0004/","tags":["x_refsource_CONFIRM"]}],"problemTypes":[{"descriptions":[{"description":"Broken Authentication","lang":"en","type":"text"}]}],"providerMetadata":{"shortName":"atlassian","dateUpdated":"2022-02-23T03:45:13.000Z","orgId":"f08a6ab8-ed46-4c22-8884-d911ccfe3c66"},"datePublic":"2021-04-13T00:00:00.000Z","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"security@atlassian.com","DATE_PUBLIC":"2021-04-13T00:00:00","ID":"CVE-2021-26073","STATE":"PUBLIC"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Atlassian Connect Express (ACE)","version":{"version_data":[{"version_affected":">=","version_value":"3.0.2"},{"version_affected":"<","version_value":"6.6.0"}]}}]},"vendor_name":"Atlassian"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Broken Authentication in Atlassian Connect Express (ACE) from version 3.0.2 before version 6.6.0: Atlassian Connect Express is a Node.js package for building Atlassian Connect apps. Authentication between Atlassian products and the Atlassian Connect Express app occurs with a server-to-server JWT or a context JWT. Atlassian Connect Express versions from 3.0.2 before 6.6.0 erroneously accept context JWTs in lifecycle endpoints (such as installation) where only server-to-server JWTs should be accepted, permitting an attacker to send authenticated re-installation events to an app."}]},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"Broken Authentication"}]}]},"references":{"reference_data":[{"name":"https://confluence.atlassian.com/pages/viewpage.action?pageId=1051986099","refsource":"MISC","url":"https://confluence.atlassian.com/pages/viewpage.action?pageId=1051986099"},{"name":"https://community.developer.atlassian.com/t/action-required-atlassian-connect-vulnerability-a[…]ypass-of-app-qsh-verification-via-context-jwts/47072","refsource":"MISC","url":"https://community.developer.atlassian.com/t/action-required-atlassian-connect-vulnerability-a[…]ypass-of-app-qsh-verification-via-context-jwts/47072"},{"name":"https://security.netapp.com/advisory/ntap-20210604-0004/","refsource":"CONFIRM","url":"https://security.netapp.com/advisory/ntap-20210604-0004/"}]}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://confluence.atlassian.com/pages/viewpage.action?pageId=1051986099","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://community.developer.atlassian.com/t/action-required-atlassian-connect-vulnerability-a%5B%E2%80%A6%5Dypass-of-app-qsh-verification-via-context-jwts/47072","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://security.netapp.com/advisory/ntap-20210604-0004/","tags":["x_refsource_CONFIRM","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T20:19:19.387Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"cvssV3_1":{"scope":"CHANGED","version":"3.1","baseScore":7.7,"attackVector":"NETWORK","baseSeverity":"HIGH","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N","integrityImpact":"HIGH","userInteraction":"NONE","attackComplexity":"LOW","availabilityImpact":"NONE","privilegesRequired":"LOW","confidentialityImpact":"NONE"}},{"other":{"type":"ssvc","content":{"timestamp":"2025-02-12T20:41:50.927822Z","id":"CVE-2021-26073","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-287","type":"CWE","lang":"en","description":"CWE-287 Improper Authentication"}]}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-02-12T20:46:54.554Z"}}]}}}