{"id":"CVE-2021-25082","state":"PUBLISHED","title":"Popup Builder < 4.0.7 - LFI to RCE","description":"The Popup Builder WordPress plugin before 4.0.7 does not validate and sanitise the sgpb_type parameter before using it in a require statement, leading to a Local File Inclusion issue. Furthermore, since the beginning of the string can be controlled, the issue can lead to RCE vulnerability via wrappers such as PHAR","publishedAt":"2022-02-21T10:45:51.000Z","updatedAt":"2024-08-03T19:56:09.873Z","severity":null,"assigner":"WPScan","products":["Unknown Popup Builder – Create highly converting, mobile friendly marketing popups."],"affected":[{"vendor":"Unknown","product":"Popup Builder – Create highly converting, mobile friendly marketing popups.","versions":[{"version":"4.0.7","status":"affected","lessThan":"4.0.7","versionType":"custom"}]}],"references":["https://wpscan.com/vulnerability/0f90f10c-4b0a-46da-ac1f-aa6a03312132","https://plugins.trac.wordpress.org/changeset/2659117"],"weaknesses":["CWE-22"],"ingestedAt":"2026-10-29T19:48:10.461Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/25xxx/CVE-2021-25082.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-25082","state":"PUBLISHED","datePublished":"2022-02-21T10:45:51.000Z","dateUpdated":"2024-08-03T19:56:09.873Z","assignerShortName":"WPScan","assignerOrgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81","dateReserved":"2021-01-14T00:00:00.000Z"},"containers":{"cna":{"title":"Popup Builder < 4.0.7 - LFI to RCE","descriptions":[{"lang":"en","value":"The Popup Builder WordPress plugin before 4.0.7 does not validate and sanitise the sgpb_type parameter before using it in a require statement, leading to a Local File Inclusion issue. Furthermore, since the beginning of the string can be controlled, the issue can lead to RCE vulnerability via wrappers such as PHAR"}],"affected":[{"vendor":"Unknown","product":"Popup Builder – Create highly converting, mobile friendly marketing popups.","versions":[{"version":"4.0.7","status":"affected","lessThan":"4.0.7","versionType":"custom"}]}],"references":[{"url":"https://wpscan.com/vulnerability/0f90f10c-4b0a-46da-ac1f-aa6a03312132","tags":["x_refsource_MISC"]},{"url":"https://plugins.trac.wordpress.org/changeset/2659117","tags":["x_refsource_CONFIRM"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-22","description":"CWE-22 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"WPScan","dateUpdated":"2022-02-21T10:45:51.000Z","orgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81"},"credits":[{"lang":"en","value":"JrXnm"}],"source":{"discovery":"EXTERNAL"},"x_generator":"WPScan CVE Generator","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"contact@wpscan.com","ID":"CVE-2021-25082","STATE":"PUBLIC","TITLE":"Popup Builder < 4.0.7 - LFI to RCE"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Popup Builder – Create highly converting, mobile friendly marketing popups.","version":{"version_data":[{"version_affected":"<","version_name":"4.0.7","version_value":"4.0.7"}]}}]},"vendor_name":"Unknown"}]}},"credit":[{"lang":"eng","value":"JrXnm"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The Popup Builder WordPress plugin before 4.0.7 does not validate and sanitise the sgpb_type parameter before using it in a require statement, leading to a Local File Inclusion issue. Furthermore, since the beginning of the string can be controlled, the issue can lead to RCE vulnerability via wrappers such as PHAR"}]},"generator":"WPScan CVE Generator","problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-22 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')"}]}]},"references":{"reference_data":[{"name":"https://wpscan.com/vulnerability/0f90f10c-4b0a-46da-ac1f-aa6a03312132","refsource":"MISC","url":"https://wpscan.com/vulnerability/0f90f10c-4b0a-46da-ac1f-aa6a03312132"},{"name":"https://plugins.trac.wordpress.org/changeset/2659117","refsource":"CONFIRM","url":"https://plugins.trac.wordpress.org/changeset/2659117"}]},"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://wpscan.com/vulnerability/0f90f10c-4b0a-46da-ac1f-aa6a03312132","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://plugins.trac.wordpress.org/changeset/2659117","tags":["x_refsource_CONFIRM","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T19:56:09.873Z"}}]}}}