{"id":"CVE-2021-24901","state":"PUBLISHED","title":"Security Audit <= 1.0.0 - Admin+ Stored Cross Site Scripting","description":"The Security Audit WordPress plugin through 1.0.0 does not sanitise and escape the Data Id setting, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.","publishedAt":"2022-02-28T09:06:17.000Z","updatedAt":"2024-08-03T19:49:13.923Z","severity":null,"assigner":"WPScan","products":["Unknown Security Audit"],"affected":[{"vendor":"Unknown","product":"Security Audit","versions":[{"version":"1.0.0","status":"affected","lessThanOrEqual":"1.0.0","versionType":"custom"}]}],"references":["https://wpscan.com/vulnerability/9c315404-b66a-448c-a3b7-367a37b53435"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:48:07.505Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/24xxx/CVE-2021-24901.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-24901","state":"PUBLISHED","datePublished":"2022-02-28T09:06:17.000Z","dateUpdated":"2024-08-03T19:49:13.923Z","assignerShortName":"WPScan","assignerOrgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81","dateReserved":"2021-01-14T00:00:00.000Z"},"containers":{"cna":{"title":"Security Audit <= 1.0.0 - Admin+ Stored Cross Site Scripting","descriptions":[{"lang":"en","value":"The Security Audit WordPress plugin through 1.0.0 does not sanitise and escape the Data Id setting, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed."}],"affected":[{"vendor":"Unknown","product":"Security Audit","versions":[{"version":"1.0.0","status":"affected","lessThanOrEqual":"1.0.0","versionType":"custom"}]}],"references":[{"url":"https://wpscan.com/vulnerability/9c315404-b66a-448c-a3b7-367a37b53435","tags":["x_refsource_MISC"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"WPScan","dateUpdated":"2022-02-28T09:06:17.000Z","orgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81"},"credits":[{"lang":"en","value":"Shweta Mahajan"}],"source":{"discovery":"EXTERNAL"},"x_generator":"WPScan CVE Generator","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"contact@wpscan.com","ID":"CVE-2021-24901","STATE":"PUBLIC","TITLE":"Security Audit <= 1.0.0 - Admin+ Stored Cross Site Scripting"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Security Audit","version":{"version_data":[{"version_affected":"<=","version_name":"1.0.0","version_value":"1.0.0"}]}}]},"vendor_name":"Unknown"}]}},"credit":[{"lang":"eng","value":"Shweta Mahajan"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The Security Audit WordPress plugin through 1.0.0 does not sanitise and escape the Data Id setting, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed."}]},"generator":"WPScan CVE Generator","problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://wpscan.com/vulnerability/9c315404-b66a-448c-a3b7-367a37b53435","refsource":"MISC","url":"https://wpscan.com/vulnerability/9c315404-b66a-448c-a3b7-367a37b53435"}]},"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://wpscan.com/vulnerability/9c315404-b66a-448c-a3b7-367a37b53435","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T19:49:13.923Z"}}]}}}