{"id":"CVE-2021-24818","state":"PUBLISHED","title":"WP Limits <= 1.0 - Plugin's Settings Update via CSRF","description":"The WP Limits WordPress plugin through 1.0 does not have CSRF check when saving its settings, allowing attacker to make a logged in admin change them, which could make the blog unstable by setting low values","publishedAt":"2021-12-13T10:41:00.000Z","updatedAt":"2024-08-03T19:42:17.201Z","severity":null,"assigner":"WPScan","products":["Unknown Wp Limits"],"affected":[{"vendor":"Unknown","product":"Wp Limits","versions":[{"version":"1.0","status":"affected","lessThanOrEqual":"1.0","versionType":"custom"}]}],"references":["https://wpscan.com/vulnerability/7cd524ed-5eb9-4d6b-b4d2-3d4be6b57879"],"weaknesses":["CWE-352"],"ingestedAt":"2026-10-29T19:48:07.505Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/24xxx/CVE-2021-24818.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-24818","state":"PUBLISHED","datePublished":"2021-12-13T10:41:00.000Z","dateUpdated":"2024-08-03T19:42:17.201Z","assignerShortName":"WPScan","assignerOrgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81","dateReserved":"2021-01-14T00:00:00.000Z"},"containers":{"cna":{"title":"WP Limits <= 1.0 - Plugin's Settings Update via CSRF","descriptions":[{"lang":"en","value":"The WP Limits WordPress plugin through 1.0 does not have CSRF check when saving its settings, allowing attacker to make a logged in admin change them, which could make the blog unstable by setting low values"}],"affected":[{"vendor":"Unknown","product":"Wp Limits","versions":[{"version":"1.0","status":"affected","lessThanOrEqual":"1.0","versionType":"custom"}]}],"references":[{"url":"https://wpscan.com/vulnerability/7cd524ed-5eb9-4d6b-b4d2-3d4be6b57879","tags":["x_refsource_MISC"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-352","description":"CWE-352 Cross-Site Request Forgery (CSRF)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"WPScan","dateUpdated":"2021-12-13T10:41:00.000Z","orgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81"},"credits":[{"lang":"en","value":"Francesco Carlucci"}],"source":{"discovery":"EXTERNAL"},"x_generator":"WPScan CVE Generator","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"contact@wpscan.com","ID":"CVE-2021-24818","STATE":"PUBLIC","TITLE":"WP Limits <= 1.0 - Plugin's Settings Update via CSRF"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Wp Limits","version":{"version_data":[{"version_affected":"<=","version_name":"1.0","version_value":"1.0"}]}}]},"vendor_name":"Unknown"}]}},"credit":[{"lang":"eng","value":"Francesco Carlucci"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The WP Limits WordPress plugin through 1.0 does not have CSRF check when saving its settings, allowing attacker to make a logged in admin change them, which could make the blog unstable by setting low values"}]},"generator":"WPScan CVE Generator","problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-352 Cross-Site Request Forgery (CSRF)"}]}]},"references":{"reference_data":[{"name":"https://wpscan.com/vulnerability/7cd524ed-5eb9-4d6b-b4d2-3d4be6b57879","refsource":"MISC","url":"https://wpscan.com/vulnerability/7cd524ed-5eb9-4d6b-b4d2-3d4be6b57879"}]},"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://wpscan.com/vulnerability/7cd524ed-5eb9-4d6b-b4d2-3d4be6b57879","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T19:42:17.201Z"}}]}}}