{"id":"CVE-2021-24789","state":"PUBLISHED","title":"Flat Preloader < 1.5.5 - Admin+ Stored Cross-Site Scripting","description":"The Flat Preloader WordPress plugin before 1.5.5 does not escape some of its settings when outputting them in attribute in the frontend, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html is disallowed","publishedAt":"2021-11-01T08:46:23.000Z","updatedAt":"2024-08-03T19:42:17.177Z","severity":null,"assigner":"WPScan","products":["Unknown Flat Preloader"],"affected":[{"vendor":"Unknown","product":"Flat Preloader","versions":[{"version":"1.5.5","status":"affected","lessThan":"1.5.5","versionType":"custom"}]}],"references":["https://wpscan.com/vulnerability/e8550ccd-3898-4e27-aca9-ade89823ff4d"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:48:07.505Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/24xxx/CVE-2021-24789.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-24789","state":"PUBLISHED","datePublished":"2021-11-01T08:46:23.000Z","dateUpdated":"2024-08-03T19:42:17.177Z","assignerShortName":"WPScan","assignerOrgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81","dateReserved":"2021-01-14T00:00:00.000Z"},"containers":{"cna":{"title":"Flat Preloader < 1.5.5 - Admin+ Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The Flat Preloader WordPress plugin before 1.5.5 does not escape some of its settings when outputting them in attribute in the frontend, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html is disallowed"}],"affected":[{"vendor":"Unknown","product":"Flat Preloader","versions":[{"version":"1.5.5","status":"affected","lessThan":"1.5.5","versionType":"custom"}]}],"references":[{"url":"https://wpscan.com/vulnerability/e8550ccd-3898-4e27-aca9-ade89823ff4d","tags":["x_refsource_MISC"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"WPScan","dateUpdated":"2021-11-01T08:46:23.000Z","orgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81"},"credits":[{"lang":"en","value":"apple502j"}],"source":{"discovery":"EXTERNAL"},"x_generator":"WPScan CVE Generator","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"contact@wpscan.com","ID":"CVE-2021-24789","STATE":"PUBLIC","TITLE":"Flat Preloader < 1.5.5 - Admin+ Stored Cross-Site Scripting"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Flat Preloader","version":{"version_data":[{"version_affected":"<","version_name":"1.5.5","version_value":"1.5.5"}]}}]},"vendor_name":"Unknown"}]}},"credit":[{"lang":"eng","value":"apple502j"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The Flat Preloader WordPress plugin before 1.5.5 does not escape some of its settings when outputting them in attribute in the frontend, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html is disallowed"}]},"generator":"WPScan CVE Generator","problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://wpscan.com/vulnerability/e8550ccd-3898-4e27-aca9-ade89823ff4d","refsource":"MISC","url":"https://wpscan.com/vulnerability/e8550ccd-3898-4e27-aca9-ade89823ff4d"}]},"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://wpscan.com/vulnerability/e8550ccd-3898-4e27-aca9-ade89823ff4d","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T19:42:17.177Z"}}]}}}