{"id":"CVE-2021-24716","state":"PUBLISHED","title":"Modern Events Calendar Lite < 5.22.3 - Authenticated Stored Cross Site Scripting","description":"The Modern Events Calendar Lite WordPress plugin before 5.22.3 does not properly sanitize or escape values set by users with access to adjust settings withing wp-admin.","publishedAt":"2021-11-01T08:46:09.000Z","updatedAt":"2024-08-03T19:42:16.663Z","severity":null,"assigner":"WPScan","products":["Unknown Modern Events Calendar Lite"],"affected":[{"vendor":"Unknown","product":"Modern Events Calendar Lite","versions":[{"version":"5.22.3","status":"affected","lessThan":"5.22.3","versionType":"custom"}]}],"references":["https://wpscan.com/vulnerability/576cc93d-1499-452b-97dd-80f69002e2a0"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:48:07.505Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/24xxx/CVE-2021-24716.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-24716","state":"PUBLISHED","datePublished":"2021-11-01T08:46:09.000Z","dateUpdated":"2024-08-03T19:42:16.663Z","assignerShortName":"WPScan","assignerOrgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81","dateReserved":"2021-01-14T00:00:00.000Z"},"containers":{"cna":{"title":"Modern Events Calendar Lite < 5.22.3 - Authenticated Stored Cross Site Scripting","descriptions":[{"lang":"en","value":"The Modern Events Calendar Lite WordPress plugin before 5.22.3 does not properly sanitize or escape values set by users with access to adjust settings withing wp-admin."}],"affected":[{"vendor":"Unknown","product":"Modern Events Calendar Lite","versions":[{"version":"5.22.3","status":"affected","lessThan":"5.22.3","versionType":"custom"}]}],"references":[{"url":"https://wpscan.com/vulnerability/576cc93d-1499-452b-97dd-80f69002e2a0","tags":["x_refsource_MISC"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"WPScan","dateUpdated":"2021-11-01T08:46:09.000Z","orgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81"},"credits":[{"lang":"en","value":"Shivam Rai"}],"source":{"discovery":"EXTERNAL"},"x_generator":"WPScan CVE Generator","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"contact@wpscan.com","ID":"CVE-2021-24716","STATE":"PUBLIC","TITLE":"Modern Events Calendar Lite < 5.22.3 - Authenticated Stored Cross Site Scripting"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Modern Events Calendar Lite","version":{"version_data":[{"version_affected":"<","version_name":"5.22.3","version_value":"5.22.3"}]}}]},"vendor_name":"Unknown"}]}},"credit":[{"lang":"eng","value":"Shivam Rai"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The Modern Events Calendar Lite WordPress plugin before 5.22.3 does not properly sanitize or escape values set by users with access to adjust settings withing wp-admin."}]},"generator":"WPScan CVE Generator","problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://wpscan.com/vulnerability/576cc93d-1499-452b-97dd-80f69002e2a0","refsource":"MISC","url":"https://wpscan.com/vulnerability/576cc93d-1499-452b-97dd-80f69002e2a0"}]},"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://wpscan.com/vulnerability/576cc93d-1499-452b-97dd-80f69002e2a0","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T19:42:16.663Z"}}]}}}