{"id":"CVE-2021-24669","state":"PUBLISHED","title":"MAZ Loader < 1.3.3 - Contributor+ SQL Injection","description":"The MAZ Loader – Preloader Builder for WordPress plugin before 1.3.3 does not validate or escape the loader_id parameter of the mzldr shortcode, which allows users with a role as low as Contributor to perform SQL injection.","publishedAt":"2021-11-08T17:34:59.000Z","updatedAt":"2024-08-03T19:42:16.136Z","severity":null,"assigner":"WPScan","products":["Unknown MAZ Loader – Preloader Builder for WordPress"],"affected":[{"vendor":"Unknown","product":"MAZ Loader – Preloader Builder for WordPress","versions":[{"version":"1.3.3","status":"affected","lessThan":"1.3.3","versionType":"custom"}]}],"references":["https://wpscan.com/vulnerability/b97afbe8-c9ae-40a2-81e5-b1d7a6b31831"],"weaknesses":["CWE-89"],"ingestedAt":"2026-10-29T19:48:07.505Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/24xxx/CVE-2021-24669.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-24669","state":"PUBLISHED","datePublished":"2021-11-08T17:34:59.000Z","dateUpdated":"2024-08-03T19:42:16.136Z","assignerShortName":"WPScan","assignerOrgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81","dateReserved":"2021-01-14T00:00:00.000Z"},"containers":{"cna":{"title":"MAZ Loader < 1.3.3 - Contributor+ SQL Injection","descriptions":[{"lang":"en","value":"The MAZ Loader – Preloader Builder for WordPress plugin before 1.3.3 does not validate or escape the loader_id parameter of the mzldr shortcode, which allows users with a role as low as Contributor to perform SQL injection."}],"affected":[{"vendor":"Unknown","product":"MAZ Loader – Preloader Builder for WordPress","versions":[{"version":"1.3.3","status":"affected","lessThan":"1.3.3","versionType":"custom"}]}],"references":[{"url":"https://wpscan.com/vulnerability/b97afbe8-c9ae-40a2-81e5-b1d7a6b31831","tags":["x_refsource_MISC"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-89","description":"CWE-89 SQL Injection","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"WPScan","dateUpdated":"2021-11-08T17:34:59.000Z","orgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81"},"credits":[{"lang":"en","value":"apple502j"}],"source":{"discovery":"EXTERNAL"},"x_generator":"WPScan CVE Generator","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"contact@wpscan.com","ID":"CVE-2021-24669","STATE":"PUBLIC","TITLE":"MAZ Loader < 1.3.3 - Contributor+ SQL Injection"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"MAZ Loader – Preloader Builder for WordPress","version":{"version_data":[{"version_affected":"<","version_name":"1.3.3","version_value":"1.3.3"}]}}]},"vendor_name":"Unknown"}]}},"credit":[{"lang":"eng","value":"apple502j"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The MAZ Loader – Preloader Builder for WordPress plugin before 1.3.3 does not validate or escape the loader_id parameter of the mzldr shortcode, which allows users with a role as low as Contributor to perform SQL injection."}]},"generator":"WPScan CVE Generator","problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-89 SQL Injection"}]}]},"references":{"reference_data":[{"name":"https://wpscan.com/vulnerability/b97afbe8-c9ae-40a2-81e5-b1d7a6b31831","refsource":"MISC","url":"https://wpscan.com/vulnerability/b97afbe8-c9ae-40a2-81e5-b1d7a6b31831"}]},"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://wpscan.com/vulnerability/b97afbe8-c9ae-40a2-81e5-b1d7a6b31831","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T19:42:16.136Z"}}]}}}