{"id":"CVE-2021-24667","state":"PUBLISHED","title":"Gallery Blocks with Lightbox < 2.2.1- Authenticated Stored Cross-Site Scripting","description":"A stored cross-site scripting vulnerability has been discovered in : Simply Gallery Blocks with Lightbox (Version – 2.2.0 & below). The vulnerability exists in the Lightbox functionality where a user with low privileges is allowed to execute arbitrary script code within the context of the application. This vulnerability is due to insufficient validation of image parameters in meta data.","publishedAt":"2021-08-30T14:11:27.000Z","updatedAt":"2024-08-03T19:42:16.073Z","severity":null,"assigner":"WPScan","products":["Unknown Gallery Blocks with Lightbox. Image Gallery, (HTML5 video , YouTube, Vimeo) Video Gallery and Lightbox for native gallery"],"affected":[{"vendor":"Unknown","product":"Gallery Blocks with Lightbox. Image Gallery, (HTML5 video , YouTube, Vimeo) Video Gallery and Lightbox for native gallery","versions":[{"version":"2.2.1","status":"affected","lessThan":"2.2.1","versionType":"custom"}]}],"references":["https://www.fortiguard.com/zeroday/FG-VD-21-060","https://wpscan.com/vulnerability/5925b263-6d6f-4a03-a98a-620150dff8f7"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:48:07.505Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/24xxx/CVE-2021-24667.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-24667","state":"PUBLISHED","datePublished":"2021-08-30T14:11:27.000Z","dateUpdated":"2024-08-03T19:42:16.073Z","assignerShortName":"WPScan","assignerOrgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81","dateReserved":"2021-01-14T00:00:00.000Z"},"containers":{"cna":{"title":"Gallery Blocks with Lightbox < 2.2.1- Authenticated Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"A stored cross-site scripting vulnerability has been discovered in : Simply Gallery Blocks with Lightbox (Version – 2.2.0 & below). The vulnerability exists in the Lightbox functionality where a user with low privileges is allowed to execute arbitrary script code within the context of the application. This vulnerability is due to insufficient validation of image parameters in meta data."}],"affected":[{"vendor":"Unknown","product":"Gallery Blocks with Lightbox. Image Gallery, (HTML5 video , YouTube, Vimeo) Video Gallery and Lightbox for native gallery","versions":[{"version":"2.2.1","status":"affected","lessThan":"2.2.1","versionType":"custom"}]}],"references":[{"url":"https://www.fortiguard.com/zeroday/FG-VD-21-060","tags":["x_refsource_MISC"]},{"url":"https://wpscan.com/vulnerability/5925b263-6d6f-4a03-a98a-620150dff8f7","tags":["x_refsource_MISC"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"WPScan","dateUpdated":"2021-08-30T14:11:27.000Z","orgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81"},"credits":[{"lang":"en","value":"Vishnupriya Ilango of Fortinet's Fortiguard Labs"}],"source":{"discovery":"UNKNOWN"},"x_generator":"WPScan CVE Generator","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"contact@wpscan.com","ID":"CVE-2021-24667","STATE":"PUBLIC","TITLE":"Gallery Blocks with Lightbox < 2.2.1- Authenticated Stored Cross-Site Scripting"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Gallery Blocks with Lightbox. Image Gallery, (HTML5 video , YouTube, Vimeo) Video Gallery and Lightbox for native gallery","version":{"version_data":[{"version_affected":"<","version_name":"2.2.1","version_value":"2.2.1"}]}}]},"vendor_name":"Unknown"}]}},"credit":[{"lang":"eng","value":"Vishnupriya Ilango of Fortinet's Fortiguard Labs"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"A stored cross-site scripting vulnerability has been discovered in : Simply Gallery Blocks with Lightbox (Version – 2.2.0 & below). The vulnerability exists in the Lightbox functionality where a user with low privileges is allowed to execute arbitrary script code within the context of the application. This vulnerability is due to insufficient validation of image parameters in meta data."}]},"generator":"WPScan CVE Generator","problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://www.fortiguard.com/zeroday/FG-VD-21-060","refsource":"MISC","url":"https://www.fortiguard.com/zeroday/FG-VD-21-060"},{"name":"https://wpscan.com/vulnerability/5925b263-6d6f-4a03-a98a-620150dff8f7","refsource":"MISC","url":"https://wpscan.com/vulnerability/5925b263-6d6f-4a03-a98a-620150dff8f7"}]},"source":{"discovery":"UNKNOWN"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.fortiguard.com/zeroday/FG-VD-21-060","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://wpscan.com/vulnerability/5925b263-6d6f-4a03-a98a-620150dff8f7","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T19:42:16.073Z"}}]}}}