{"id":"CVE-2021-24546","state":"PUBLISHED","title":"EditorsKit < 1.31.6 - Contributor+ Arbitrary PHP Code Execution","description":"The Gutenberg Block Editor Toolkit – EditorsKit WordPress plugin before 1.31.6 does not sanitise and validate the Conditional Logic of the Custom Visibility settings, allowing users with a role as low contributor to execute Arbitrary PHP code","publishedAt":"2021-10-11T10:45:29.000Z","updatedAt":"2024-08-03T19:35:20.035Z","severity":null,"assigner":"WPScan","products":["Unknown Gutenberg Block Editor Toolkit – EditorsKit"],"affected":[{"vendor":"Unknown","product":"Gutenberg Block Editor Toolkit – EditorsKit","versions":[{"version":"1.31.6","status":"affected","lessThan":"1.31.6","versionType":"custom"}]}],"references":["https://wpscan.com/vulnerability/bdc36f6a-682d-4d66-b587-92e86085d971"],"weaknesses":["CWE-94"],"ingestedAt":"2026-10-29T19:48:07.505Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/24xxx/CVE-2021-24546.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-24546","state":"PUBLISHED","datePublished":"2021-10-11T10:45:29.000Z","dateUpdated":"2024-08-03T19:35:20.035Z","assignerShortName":"WPScan","assignerOrgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81","dateReserved":"2021-01-14T00:00:00.000Z"},"containers":{"cna":{"title":"EditorsKit < 1.31.6 - Contributor+ Arbitrary PHP Code Execution","descriptions":[{"lang":"en","value":"The Gutenberg Block Editor Toolkit – EditorsKit WordPress plugin before 1.31.6 does not sanitise and validate the Conditional Logic of the Custom Visibility settings, allowing users with a role as low contributor to execute Arbitrary PHP code"}],"affected":[{"vendor":"Unknown","product":"Gutenberg Block Editor Toolkit – EditorsKit","versions":[{"version":"1.31.6","status":"affected","lessThan":"1.31.6","versionType":"custom"}]}],"references":[{"url":"https://wpscan.com/vulnerability/bdc36f6a-682d-4d66-b587-92e86085d971","tags":["x_refsource_MISC"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-94","description":"CWE-94 Improper Control of Generation of Code ('Code Injection')","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"WPScan","dateUpdated":"2021-10-11T10:45:28.000Z","orgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81"},"credits":[{"lang":"en","value":"bl4derunner"}],"source":{"discovery":"EXTERNAL"},"x_generator":"WPScan CVE Generator","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"contact@wpscan.com","ID":"CVE-2021-24546","STATE":"PUBLIC","TITLE":"EditorsKit < 1.31.6 - Contributor+ Arbitrary PHP Code Execution"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Gutenberg Block Editor Toolkit – EditorsKit","version":{"version_data":[{"version_affected":"<","version_name":"1.31.6","version_value":"1.31.6"}]}}]},"vendor_name":"Unknown"}]}},"credit":[{"lang":"eng","value":"bl4derunner"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The Gutenberg Block Editor Toolkit – EditorsKit WordPress plugin before 1.31.6 does not sanitise and validate the Conditional Logic of the Custom Visibility settings, allowing users with a role as low contributor to execute Arbitrary PHP code"}]},"generator":"WPScan CVE Generator","problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-94 Improper Control of Generation of Code ('Code Injection')"}]}]},"references":{"reference_data":[{"name":"https://wpscan.com/vulnerability/bdc36f6a-682d-4d66-b587-92e86085d971","refsource":"MISC","url":"https://wpscan.com/vulnerability/bdc36f6a-682d-4d66-b587-92e86085d971"}]},"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://wpscan.com/vulnerability/bdc36f6a-682d-4d66-b587-92e86085d971","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T19:35:20.035Z"}}]}}}