{"id":"CVE-2021-24541","state":"PUBLISHED","title":"Wonder PDF Embed < 1.7 - Contributor+ Stored XSS","description":"The Wonder PDF Embed WordPress plugin before 1.7 does not escape parameters of its wonderplugin_pdf shortcode, which could allow users with a role as low as Contributor to perform Stored XSS attacks.","publishedAt":"2021-08-16T10:48:32.000Z","updatedAt":"2024-08-03T19:35:20.103Z","severity":null,"assigner":"WPScan","products":["Unknown Wonder PDF Embed"],"affected":[{"vendor":"Unknown","product":"Wonder PDF Embed","versions":[{"version":"1.7","status":"affected","lessThan":"1.7","versionType":"custom"}]}],"references":["https://wpscan.com/vulnerability/e6602369-87f4-4454-8298-89cc69f8375c"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:48:07.505Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/24xxx/CVE-2021-24541.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-24541","state":"PUBLISHED","datePublished":"2021-08-16T10:48:32.000Z","dateUpdated":"2024-08-03T19:35:20.103Z","assignerShortName":"WPScan","assignerOrgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81","dateReserved":"2021-01-14T00:00:00.000Z"},"containers":{"cna":{"title":"Wonder PDF Embed < 1.7 - Contributor+ Stored XSS","descriptions":[{"lang":"en","value":"The Wonder PDF Embed WordPress plugin before 1.7 does not escape parameters of its wonderplugin_pdf shortcode, which could allow users with a role as low as Contributor to perform Stored XSS attacks."}],"affected":[{"vendor":"Unknown","product":"Wonder PDF Embed","versions":[{"version":"1.7","status":"affected","lessThan":"1.7","versionType":"custom"}]}],"references":[{"url":"https://wpscan.com/vulnerability/e6602369-87f4-4454-8298-89cc69f8375c","tags":["x_refsource_MISC"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"WPScan","dateUpdated":"2021-08-16T10:48:32.000Z","orgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81"},"credits":[{"lang":"en","value":"apple502j"}],"source":{"discovery":"UNKNOWN"},"x_generator":"WPScan CVE Generator","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"contact@wpscan.com","ID":"CVE-2021-24541","STATE":"PUBLIC","TITLE":"Wonder PDF Embed < 1.7 - Contributor+ Stored XSS"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Wonder PDF Embed","version":{"version_data":[{"version_affected":"<","version_name":"1.7","version_value":"1.7"}]}}]},"vendor_name":"Unknown"}]}},"credit":[{"lang":"eng","value":"apple502j"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The Wonder PDF Embed WordPress plugin before 1.7 does not escape parameters of its wonderplugin_pdf shortcode, which could allow users with a role as low as Contributor to perform Stored XSS attacks."}]},"generator":"WPScan CVE Generator","problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://wpscan.com/vulnerability/e6602369-87f4-4454-8298-89cc69f8375c","refsource":"MISC","url":"https://wpscan.com/vulnerability/e6602369-87f4-4454-8298-89cc69f8375c"}]},"source":{"discovery":"UNKNOWN"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://wpscan.com/vulnerability/e6602369-87f4-4454-8298-89cc69f8375c","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T19:35:20.103Z"}}]}}}