{"id":"CVE-2021-24533","state":"PUBLISHED","title":"Maintenance < 4.03 - Authenticated Stored XSS","description":"The Maintenance WordPress plugin before 4.03 does not sanitise or escape some of its settings, allowing high privilege users such as admin to se Cross-Site Scripting payload in them (even when the unfiltered_html capability is disallowed), which will be triggered in the frontend","publishedAt":"2021-08-23T11:10:01.000Z","updatedAt":"2024-08-03T19:35:19.939Z","severity":null,"assigner":"WPScan","products":["Unknown Maintenance"],"affected":[{"vendor":"Unknown","product":"Maintenance","versions":[{"version":"4.03","status":"affected","lessThan":"4.03","versionType":"custom"}]}],"references":["https://wpscan.com/vulnerability/174b2119-b806-4da4-a23d-c19b552c86cb"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:48:07.505Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/24xxx/CVE-2021-24533.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-24533","state":"PUBLISHED","datePublished":"2021-08-23T11:10:01.000Z","dateUpdated":"2024-08-03T19:35:19.939Z","assignerShortName":"WPScan","assignerOrgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81","dateReserved":"2021-01-14T00:00:00.000Z"},"containers":{"cna":{"title":"Maintenance < 4.03 - Authenticated Stored XSS","descriptions":[{"lang":"en","value":"The Maintenance WordPress plugin before 4.03 does not sanitise or escape some of its settings, allowing high privilege users such as admin to se Cross-Site Scripting payload in them (even when the unfiltered_html capability is disallowed), which will be triggered in the frontend"}],"affected":[{"vendor":"Unknown","product":"Maintenance","versions":[{"version":"4.03","status":"affected","lessThan":"4.03","versionType":"custom"}]}],"references":[{"url":"https://wpscan.com/vulnerability/174b2119-b806-4da4-a23d-c19b552c86cb","tags":["x_refsource_MISC"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"WPScan","dateUpdated":"2021-08-23T11:10:01.000Z","orgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81"},"credits":[{"lang":"en","value":"Emil kylander"}],"source":{"discovery":"UNKNOWN"},"x_generator":"WPScan CVE Generator","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"contact@wpscan.com","ID":"CVE-2021-24533","STATE":"PUBLIC","TITLE":"Maintenance < 4.03 - Authenticated Stored XSS"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Maintenance","version":{"version_data":[{"version_affected":"<","version_name":"4.03","version_value":"4.03"}]}}]},"vendor_name":"Unknown"}]}},"credit":[{"lang":"eng","value":"Emil kylander"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The Maintenance WordPress plugin before 4.03 does not sanitise or escape some of its settings, allowing high privilege users such as admin to se Cross-Site Scripting payload in them (even when the unfiltered_html capability is disallowed), which will be triggered in the frontend"}]},"generator":"WPScan CVE Generator","problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://wpscan.com/vulnerability/174b2119-b806-4da4-a23d-c19b552c86cb","refsource":"MISC","url":"https://wpscan.com/vulnerability/174b2119-b806-4da4-a23d-c19b552c86cb"}]},"source":{"discovery":"UNKNOWN"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://wpscan.com/vulnerability/174b2119-b806-4da4-a23d-c19b552c86cb","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T19:35:19.939Z"}}]}}}