{"id":"CVE-2021-24413","state":"PUBLISHED","title":"Easy Twitter Feed < 1.2 - Contributor+ Stored Cross-Site Scripting","description":"The Easy Twitter Feed WordPress plugin before 1.2 does not sanitise or validate the parameters from its shortcode, allowing users with a role as low as contributor to set Cross-Site Scripting payload in them which will be triggered in the page/s with the embed malicious shortcode","publishedAt":"2021-10-18T13:45:38.000Z","updatedAt":"2024-08-03T19:28:23.838Z","severity":null,"assigner":"WPScan","products":["Unknown Easy Twitter Feed"],"affected":[{"vendor":"Unknown","product":"Easy Twitter Feed","versions":[{"version":"1.2","status":"affected","lessThan":"1.2","versionType":"custom"}]}],"references":["https://wpscan.com/vulnerability/ce6d17c3-6741-4c80-ab13-e1824960ae24"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:48:07.505Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/24xxx/CVE-2021-24413.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-24413","state":"PUBLISHED","datePublished":"2021-10-18T13:45:38.000Z","dateUpdated":"2024-08-03T19:28:23.838Z","assignerShortName":"WPScan","assignerOrgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81","dateReserved":"2021-01-14T00:00:00.000Z"},"containers":{"cna":{"title":"Easy Twitter Feed < 1.2 - Contributor+ Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The Easy Twitter Feed WordPress plugin before 1.2 does not sanitise or validate the parameters from its shortcode, allowing users with a role as low as contributor to set Cross-Site Scripting payload in them which will be triggered in the page/s with the embed malicious shortcode"}],"affected":[{"vendor":"Unknown","product":"Easy Twitter Feed","versions":[{"version":"1.2","status":"affected","lessThan":"1.2","versionType":"custom"}]}],"references":[{"url":"https://wpscan.com/vulnerability/ce6d17c3-6741-4c80-ab13-e1824960ae24","tags":["x_refsource_MISC"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"WPScan","dateUpdated":"2021-10-18T13:45:38.000Z","orgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81"},"credits":[{"lang":"en","value":"Michał Lipiński"}],"source":{"discovery":"EXTERNAL"},"x_generator":"WPScan CVE Generator","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"contact@wpscan.com","ID":"CVE-2021-24413","STATE":"PUBLIC","TITLE":"Easy Twitter Feed < 1.2 - Contributor+ Stored Cross-Site Scripting"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Easy Twitter Feed","version":{"version_data":[{"version_affected":"<","version_name":"1.2","version_value":"1.2"}]}}]},"vendor_name":"Unknown"}]}},"credit":[{"lang":"eng","value":"Michał Lipiński"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The Easy Twitter Feed WordPress plugin before 1.2 does not sanitise or validate the parameters from its shortcode, allowing users with a role as low as contributor to set Cross-Site Scripting payload in them which will be triggered in the page/s with the embed malicious shortcode"}]},"generator":"WPScan CVE Generator","problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://wpscan.com/vulnerability/ce6d17c3-6741-4c80-ab13-e1824960ae24","refsource":"MISC","url":"https://wpscan.com/vulnerability/ce6d17c3-6741-4c80-ab13-e1824960ae24"}]},"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://wpscan.com/vulnerability/ce6d17c3-6741-4c80-ab13-e1824960ae24","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T19:28:23.838Z"}}]}}}