{"id":"CVE-2021-24382","state":"PUBLISHED","title":"Smart Slider 3 < 3.5.0.9 - Authenticated Stored Cross-Site Scripting (XSS)","description":"The Smart Slider 3 Free and pro WordPress plugins before 3.5.0.9 did not sanitise the Project Name before outputting it back in the page, leading to a Stored Cross-Site Scripting issue. By default, only administrator users could access the affected functionality, limiting the exploitability of the vulnerability. However, some WordPress admins may allow lesser privileged users to access the plugin's functionality, in which case, privilege escalation could be performed.","publishedAt":"2021-06-14T13:37:14.000Z","updatedAt":"2024-08-03T19:28:23.902Z","severity":null,"assigner":"WPScan","products":["Nextend Smart Slider 3"],"affected":[{"vendor":"Nextend","product":"Smart Slider 3","versions":[{"version":"3.5.0.9","status":"affected","lessThan":"3.5.0.9","versionType":"custom"}]},{"vendor":"Nextend","product":"Smart Slider 3","versions":[{"version":"3.5.0.9","status":"affected","lessThan":"3.5.0.9","versionType":"custom"}]}],"references":["https://wpscan.com/vulnerability/7b32a282-e51f-4ee5-b59f-5ba10e62a54d","https://smartslider.helpscoutdocs.com/article/1746-changelog"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:48:07.505Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/24xxx/CVE-2021-24382.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-24382","state":"PUBLISHED","datePublished":"2021-06-14T13:37:14.000Z","dateUpdated":"2024-08-03T19:28:23.902Z","assignerShortName":"WPScan","assignerOrgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81","dateReserved":"2021-01-14T00:00:00.000Z"},"containers":{"cna":{"title":"Smart Slider 3 < 3.5.0.9 - Authenticated Stored Cross-Site Scripting (XSS)","descriptions":[{"lang":"en","value":"The Smart Slider 3 Free and pro WordPress plugins before 3.5.0.9 did not sanitise the Project Name before outputting it back in the page, leading to a Stored Cross-Site Scripting issue. By default, only administrator users could access the affected functionality, limiting the exploitability of the vulnerability. However, some WordPress admins may allow lesser privileged users to access the plugin's functionality, in which case, privilege escalation could be performed."}],"affected":[{"vendor":"Nextend","product":"Smart Slider 3","versions":[{"version":"3.5.0.9","status":"affected","lessThan":"3.5.0.9","versionType":"custom"}]},{"vendor":"Nextend","product":"Smart Slider 3","versions":[{"version":"3.5.0.9","status":"affected","lessThan":"3.5.0.9","versionType":"custom"}]}],"references":[{"url":"https://wpscan.com/vulnerability/7b32a282-e51f-4ee5-b59f-5ba10e62a54d","tags":["x_refsource_CONFIRM"]},{"url":"https://smartslider.helpscoutdocs.com/article/1746-changelog","tags":["x_refsource_MISC"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"WPScan","dateUpdated":"2021-06-14T13:37:14.000Z","orgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81"},"credits":[{"lang":"en","value":"Hardik Solanki"},{"lang":"en","value":"blackangel"}],"source":{"discovery":"UNKNOWN"},"x_generator":"WPScan CVE Generator","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"contact@wpscan.com","ID":"CVE-2021-24382","STATE":"PUBLIC","TITLE":"Smart Slider 3 < 3.5.0.9 - Authenticated Stored Cross-Site Scripting (XSS)"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Smart Slider 3","version":{"version_data":[{"version_affected":"<","version_name":"3.5.0.9","version_value":"3.5.0.9"}]}},{"product_name":"Smart Slider 3","version":{"version_data":[{"version_affected":"<","version_name":"3.5.0.9","version_value":"3.5.0.9"}]}}]},"vendor_name":"Nextend"}]}},"credit":[{"lang":"eng","value":"Hardik Solanki"},{"lang":"eng","value":"blackangel"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The Smart Slider 3 Free and pro WordPress plugins before 3.5.0.9 did not sanitise the Project Name before outputting it back in the page, leading to a Stored Cross-Site Scripting issue. By default, only administrator users could access the affected functionality, limiting the exploitability of the vulnerability. However, some WordPress admins may allow lesser privileged users to access the plugin's functionality, in which case, privilege escalation could be performed."}]},"generator":"WPScan CVE Generator","problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://wpscan.com/vulnerability/7b32a282-e51f-4ee5-b59f-5ba10e62a54d","refsource":"CONFIRM","url":"https://wpscan.com/vulnerability/7b32a282-e51f-4ee5-b59f-5ba10e62a54d"},{"name":"https://smartslider.helpscoutdocs.com/article/1746-changelog","refsource":"MISC","url":"https://smartslider.helpscoutdocs.com/article/1746-changelog"}]},"source":{"discovery":"UNKNOWN"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://wpscan.com/vulnerability/7b32a282-e51f-4ee5-b59f-5ba10e62a54d","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://smartslider.helpscoutdocs.com/article/1746-changelog","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T19:28:23.902Z"}}]}}}