{"id":"CVE-2021-24270","state":"PUBLISHED","title":"DethemeKit For Elementor < 1.5.5.5 - Contributor+ Stored XSS","description":"The “DeTheme Kit for Elementor” WordPress Plugin before 1.5.5.5 has a widget that is vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, all via a similar method.","publishedAt":"2021-05-05T18:28:47.000Z","updatedAt":"2024-08-03T19:28:22.694Z","severity":null,"assigner":"WPScan","products":["Unknown DethemeKit For Elementor"],"affected":[{"vendor":"Unknown","product":"DethemeKit For Elementor","versions":[{"version":"1.5.5.5","status":"affected","lessThan":"1.5.5.5","versionType":"custom"}]}],"references":["https://www.wordfence.com/blog/2021/04/recent-patches-rock-the-elementor-ecosystem/","https://wpscan.com/vulnerability/67967784-18b6-4e41-9597-3a4c051f3978"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:48:07.505Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/24xxx/CVE-2021-24270.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-24270","state":"PUBLISHED","datePublished":"2021-05-05T18:28:47.000Z","dateUpdated":"2024-08-03T19:28:22.694Z","assignerShortName":"WPScan","assignerOrgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81","dateReserved":"2021-01-14T00:00:00.000Z"},"containers":{"cna":{"title":"DethemeKit For Elementor < 1.5.5.5 - Contributor+ Stored XSS","descriptions":[{"lang":"en","value":"The “DeTheme Kit for Elementor” WordPress Plugin before 1.5.5.5 has a widget that is vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, all via a similar method."}],"affected":[{"vendor":"Unknown","product":"DethemeKit For Elementor","versions":[{"version":"1.5.5.5","status":"affected","lessThan":"1.5.5.5","versionType":"custom"}]}],"references":[{"url":"https://www.wordfence.com/blog/2021/04/recent-patches-rock-the-elementor-ecosystem/","tags":["x_refsource_MISC"]},{"url":"https://wpscan.com/vulnerability/67967784-18b6-4e41-9597-3a4c051f3978","tags":["x_refsource_CONFIRM"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"WPScan","dateUpdated":"2021-05-05T18:28:47.000Z","orgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81"},"credits":[{"lang":"en","value":"Ramuel Gall"}],"source":{"discovery":"UNKNOWN"},"x_generator":"WPScan CVE Generator","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"contact@wpscan.com","ID":"CVE-2021-24270","STATE":"PUBLIC","TITLE":"DethemeKit For Elementor < 1.5.5.5 - Contributor+ Stored XSS"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"DethemeKit For Elementor","version":{"version_data":[{"version_affected":"<","version_name":"1.5.5.5","version_value":"1.5.5.5"}]}}]},"vendor_name":"Unknown"}]}},"credit":[{"lang":"eng","value":"Ramuel Gall"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The “DeTheme Kit for Elementor” WordPress Plugin before 1.5.5.5 has a widget that is vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, all via a similar method."}]},"generator":"WPScan CVE Generator","problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://www.wordfence.com/blog/2021/04/recent-patches-rock-the-elementor-ecosystem/","refsource":"MISC","url":"https://www.wordfence.com/blog/2021/04/recent-patches-rock-the-elementor-ecosystem/"},{"name":"https://wpscan.com/vulnerability/67967784-18b6-4e41-9597-3a4c051f3978","refsource":"CONFIRM","url":"https://wpscan.com/vulnerability/67967784-18b6-4e41-9597-3a4c051f3978"}]},"source":{"discovery":"UNKNOWN"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.wordfence.com/blog/2021/04/recent-patches-rock-the-elementor-ecosystem/","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://wpscan.com/vulnerability/67967784-18b6-4e41-9597-3a4c051f3978","tags":["x_refsource_CONFIRM","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T19:28:22.694Z"}}]}}}