{"id":"CVE-2021-24189","state":"PUBLISHED","title":"Captchinoo, Google recaptcha for admin login page < 2.4 - Arbitrary Plugin Installation/Activation via Low Privilege User","description":"Low privileged users can use the AJAX action 'cp_plugins_do_button_job_later_callback' in the Captchinoo, Google recaptcha for admin login page WordPress plugin before 2.4, to install any plugin (including a specific version) from the WordPress repository, as well as activate arbitrary plugin from then blog, which helps attackers install vulnerable plugins and could lead to more critical vulnerabilities like RCE.","publishedAt":"2021-05-14T11:38:16.000Z","updatedAt":"2024-08-03T19:21:18.661Z","severity":null,"assigner":"WPScan","products":["wp-buy Captchinoo, Google recaptcha for admin login page"],"affected":[{"vendor":"wp-buy","product":"Captchinoo, Google recaptcha for admin login page","versions":[{"version":"2.4","status":"affected","lessThan":"2.4","versionType":"custom"}]}],"references":["https://wpscan.com/vulnerability/74889e29-5349-43d1-baf5-1622493be90c"],"weaknesses":["CWE-285"],"ingestedAt":"2026-10-29T19:48:07.505Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/24xxx/CVE-2021-24189.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-24189","state":"PUBLISHED","datePublished":"2021-05-14T11:38:16.000Z","dateUpdated":"2024-08-03T19:21:18.661Z","assignerShortName":"WPScan","assignerOrgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81","dateReserved":"2021-01-14T00:00:00.000Z"},"containers":{"cna":{"title":"Captchinoo, Google recaptcha for admin login page < 2.4 - Arbitrary Plugin Installation/Activation via Low Privilege User","descriptions":[{"lang":"en","value":"Low privileged users can use the AJAX action 'cp_plugins_do_button_job_later_callback' in the Captchinoo, Google recaptcha for admin login page WordPress plugin before 2.4, to install any plugin (including a specific version) from the WordPress repository, as well as activate arbitrary plugin from then blog, which helps attackers install vulnerable plugins and could lead to more critical vulnerabilities like RCE."}],"affected":[{"vendor":"wp-buy","product":"Captchinoo, Google recaptcha for admin login page","versions":[{"version":"2.4","status":"affected","lessThan":"2.4","versionType":"custom"}]}],"references":[{"url":"https://wpscan.com/vulnerability/74889e29-5349-43d1-baf5-1622493be90c","tags":["x_refsource_CONFIRM"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-285","description":"CWE-285 Improper Authorization","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"WPScan","dateUpdated":"2021-05-14T11:38:16.000Z","orgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81"},"credits":[{"lang":"en","value":"Bugbang"}],"source":{"discovery":"UNKNOWN"},"x_generator":"WPScan CVE Generator","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"contact@wpscan.com","ID":"CVE-2021-24189","STATE":"PUBLIC","TITLE":"Captchinoo, Google recaptcha for admin login page < 2.4 - Arbitrary Plugin Installation/Activation via Low Privilege User"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Captchinoo, Google recaptcha for admin login page","version":{"version_data":[{"version_affected":"<","version_name":"2.4","version_value":"2.4"}]}}]},"vendor_name":"wp-buy"}]}},"credit":[{"lang":"eng","value":"Bugbang"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Low privileged users can use the AJAX action 'cp_plugins_do_button_job_later_callback' in the Captchinoo, Google recaptcha for admin login page WordPress plugin before 2.4, to install any plugin (including a specific version) from the WordPress repository, as well as activate arbitrary plugin from then blog, which helps attackers install vulnerable plugins and could lead to more critical vulnerabilities like RCE."}]},"generator":"WPScan CVE Generator","problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-285 Improper Authorization"}]}]},"references":{"reference_data":[{"name":"https://wpscan.com/vulnerability/74889e29-5349-43d1-baf5-1622493be90c","refsource":"CONFIRM","url":"https://wpscan.com/vulnerability/74889e29-5349-43d1-baf5-1622493be90c"}]},"source":{"discovery":"UNKNOWN"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://wpscan.com/vulnerability/74889e29-5349-43d1-baf5-1622493be90c","tags":["x_refsource_CONFIRM","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T19:21:18.661Z"}}]}}}