{"id":"CVE-2021-22895","state":"PUBLISHED","title":"Nextcloud Desktop Client before 3.3.1 is vulnerable to improper certificate validation due to lack of SSL certificate verification when using the \"Register with a Provider\" flow.","description":"Nextcloud Desktop Client before 3.3.1 is vulnerable to improper certificate validation due to lack of SSL certificate verification when using the \"Register with a Provider\" flow.","publishedAt":"2021-06-11T15:49:38.000Z","updatedAt":"2024-08-03T18:58:25.644Z","severity":null,"assigner":"hackerone","products":["n/a Nextcloud Desktop Client"],"affected":[{"vendor":"n/a","product":"Nextcloud Desktop Client","versions":[{"version":"Fixed in 3.3.1","status":"affected"}]}],"references":["https://hackerone.com/reports/903424","https://github.com/nextcloud/desktop/pull/2926","https://github.com/nextcloud/desktop/releases/tag/v3.1.3","https://github.com/nextcloud/security-advisories/security/advisories/GHSA-qpgp-vf4p-wcw5","https://www.debian.org/security/2021/dsa-4974"],"weaknesses":["CWE-295"],"ingestedAt":"2026-10-29T19:48:02.192Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/22xxx/CVE-2021-22895.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-22895","state":"PUBLISHED","datePublished":"2021-06-11T15:49:38.000Z","dateUpdated":"2024-08-03T18:58:25.644Z","assignerShortName":"hackerone","assignerOrgId":"36234546-b8fa-4601-9d6f-f4e334aa8ea1","dateReserved":"2021-01-06T00:00:00.000Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"Nextcloud Desktop Client before 3.3.1 is vulnerable to improper certificate validation due to lack of SSL certificate verification when using the \"Register with a Provider\" flow."}],"affected":[{"vendor":"n/a","product":"Nextcloud Desktop Client","versions":[{"version":"Fixed in 3.3.1","status":"affected"}]}],"references":[{"url":"https://hackerone.com/reports/903424","tags":["x_refsource_MISC"]},{"url":"https://github.com/nextcloud/desktop/pull/2926","tags":["x_refsource_MISC"]},{"url":"https://github.com/nextcloud/desktop/releases/tag/v3.1.3","tags":["x_refsource_MISC"]},{"url":"https://github.com/nextcloud/security-advisories/security/advisories/GHSA-qpgp-vf4p-wcw5","tags":["x_refsource_MISC"]},{"url":"https://www.debian.org/security/2021/dsa-4974","name":"DSA-4974","tags":["vendor-advisory","x_refsource_DEBIAN"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-295","description":"Improper Certificate Validation (CWE-295)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"hackerone","dateUpdated":"2021-09-19T23:06:09.000Z","orgId":"36234546-b8fa-4601-9d6f-f4e334aa8ea1"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"support@hackerone.com","ID":"CVE-2021-22895","STATE":"PUBLIC"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Nextcloud Desktop Client","version":{"version_data":[{"version_value":"Fixed in 3.3.1"}]}}]},"vendor_name":"n/a"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Nextcloud Desktop Client before 3.3.1 is vulnerable to improper certificate validation due to lack of SSL certificate verification when using the \"Register with a Provider\" flow."}]},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"Improper Certificate Validation (CWE-295)"}]}]},"references":{"reference_data":[{"name":"https://hackerone.com/reports/903424","refsource":"MISC","url":"https://hackerone.com/reports/903424"},{"name":"https://github.com/nextcloud/desktop/pull/2926","refsource":"MISC","url":"https://github.com/nextcloud/desktop/pull/2926"},{"name":"https://github.com/nextcloud/desktop/releases/tag/v3.1.3","refsource":"MISC","url":"https://github.com/nextcloud/desktop/releases/tag/v3.1.3"},{"name":"https://github.com/nextcloud/security-advisories/security/advisories/GHSA-qpgp-vf4p-wcw5","refsource":"MISC","url":"https://github.com/nextcloud/security-advisories/security/advisories/GHSA-qpgp-vf4p-wcw5"},{"name":"DSA-4974","refsource":"DEBIAN","url":"https://www.debian.org/security/2021/dsa-4974"}]}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://hackerone.com/reports/903424","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://github.com/nextcloud/desktop/pull/2926","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://github.com/nextcloud/desktop/releases/tag/v3.1.3","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://github.com/nextcloud/security-advisories/security/advisories/GHSA-qpgp-vf4p-wcw5","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://www.debian.org/security/2021/dsa-4974","name":"DSA-4974","tags":["vendor-advisory","x_refsource_DEBIAN","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T18:58:25.644Z"}}]}}}