{"id":"CVE-2021-22116","state":"PUBLISHED","title":"RabbitMQ all versions prior to 3.8.16 are prone to a denial of service vulnerability due to improper input validation in AMQP 1.0 client connection endpoint. A malicious user can e","description":"RabbitMQ all versions prior to 3.8.16 are prone to a denial of service vulnerability due to improper input validation in AMQP 1.0 client connection endpoint. A malicious user can exploit the vulnerability by sending malicious AMQP messages to the target RabbitMQ instance having the AMQP 1.0 plugin enabled.","publishedAt":"2021-06-08T11:23:58.000Z","updatedAt":"2024-08-03T18:30:23.992Z","severity":null,"assigner":"vmware","products":["n/a RabbitMQ"],"affected":[{"vendor":"n/a","product":"RabbitMQ","versions":[{"version":"RabbitMQ  prior to version 3.8.16","status":"affected"}]}],"references":["https://tanzu.vmware.com/security/cve-2021-22116","https://lists.debian.org/debian-lts-announce/2021/07/msg00011.html"],"weaknesses":["CWE-400"],"ingestedAt":"2026-10-29T19:48:02.192Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/22xxx/CVE-2021-22116.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-22116","state":"PUBLISHED","datePublished":"2021-06-08T11:23:58.000Z","dateUpdated":"2024-08-03T18:30:23.992Z","assignerShortName":"vmware","assignerOrgId":"dcf2e128-44bd-42ed-91e8-88f912c1401d","dateReserved":"2021-01-04T00:00:00.000Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"RabbitMQ all versions prior to 3.8.16 are prone to a denial of service vulnerability due to improper input validation in AMQP 1.0 client connection endpoint. A malicious user can exploit the vulnerability by sending malicious AMQP messages to the target RabbitMQ instance having the AMQP 1.0 plugin enabled."}],"affected":[{"vendor":"n/a","product":"RabbitMQ","versions":[{"version":"RabbitMQ  prior to version 3.8.16","status":"affected"}]}],"references":[{"url":"https://tanzu.vmware.com/security/cve-2021-22116","tags":["x_refsource_MISC"]},{"url":"https://lists.debian.org/debian-lts-announce/2021/07/msg00011.html","name":"[debian-lts-announce] 20210719 [SECURITY] [DLA 2710-1] rabbitmq-server security update","tags":["mailing-list","x_refsource_MLIST"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-400","description":"CWE-400: Uncontrolled Resource Consumption","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"vmware","dateUpdated":"2021-07-19T19:06:20.000Z","orgId":"dcf2e128-44bd-42ed-91e8-88f912c1401d"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"security@vmware.com","ID":"CVE-2021-22116","STATE":"PUBLIC"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"RabbitMQ","version":{"version_data":[{"version_value":"RabbitMQ  prior to version 3.8.16"}]}}]},"vendor_name":"n/a"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"RabbitMQ all versions prior to 3.8.16 are prone to a denial of service vulnerability due to improper input validation in AMQP 1.0 client connection endpoint. A malicious user can exploit the vulnerability by sending malicious AMQP messages to the target RabbitMQ instance having the AMQP 1.0 plugin enabled."}]},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-400: Uncontrolled Resource Consumption"}]}]},"references":{"reference_data":[{"name":"https://tanzu.vmware.com/security/cve-2021-22116","refsource":"MISC","url":"https://tanzu.vmware.com/security/cve-2021-22116"},{"name":"[debian-lts-announce] 20210719 [SECURITY] [DLA 2710-1] rabbitmq-server security update","refsource":"MLIST","url":"https://lists.debian.org/debian-lts-announce/2021/07/msg00011.html"}]}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://tanzu.vmware.com/security/cve-2021-22116","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://lists.debian.org/debian-lts-announce/2021/07/msg00011.html","name":"[debian-lts-announce] 20210719 [SECURITY] [DLA 2710-1] rabbitmq-server security update","tags":["mailing-list","x_refsource_MLIST","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T18:30:23.992Z"}}]}}}