{"id":"CVE-2021-21258","state":"PUBLISHED","title":"XSS injection in ajax/kanban","description":"GLPI is an open-source asset and IT management software package that provides ITIL Service Desk features, licenses tracking and software auditing. In GLPI from version 9.5.0 and before version 9.5.4, there is a cross-site scripting injection vulnerability when using ajax/kanban.php. This is fixed in version 9.5.4.","publishedAt":"2021-03-02T19:45:17.000Z","updatedAt":"2024-08-03T18:09:14.957Z","severity":{"score":6.8,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:N/I:H/A:N","source":"GitHub_M"},"assigner":"GitHub_M","products":["glpi-project glpi"],"affected":[{"vendor":"glpi-project","product":"glpi","versions":[{"version":">= 9.5.0, < 9.5.4","status":"affected"}]}],"references":["https://github.com/glpi-project/glpi/security/advisories/GHSA-j4xj-4qmc-mmmx","https://github.com/glpi-project/glpi/commit/e7802fc051696de1f76108ea8dc3bd4e2c880f15"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:47:59.168Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/21xxx/CVE-2021-21258.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-21258","state":"PUBLISHED","datePublished":"2021-03-02T19:45:17.000Z","dateUpdated":"2024-08-03T18:09:14.957Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2020-12-22T00:00:00.000Z"},"containers":{"cna":{"title":"XSS injection in ajax/kanban","descriptions":[{"lang":"en","value":"GLPI is an open-source asset and IT management software package that provides ITIL Service Desk features, licenses tracking and software auditing. In GLPI from version 9.5.0 and before version 9.5.4, there is a cross-site scripting injection vulnerability when using ajax/kanban.php. This is fixed in version 9.5.4."}],"affected":[{"vendor":"glpi-project","product":"glpi","versions":[{"version":">= 9.5.0, < 9.5.4","status":"affected"}]}],"references":[{"url":"https://github.com/glpi-project/glpi/security/advisories/GHSA-j4xj-4qmc-mmmx","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/glpi-project/glpi/commit/e7802fc051696de1f76108ea8dc3bd4e2c880f15","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":6.8,"baseSeverity":"MEDIUM","confidentialityImpact":"NONE","integrityImpact":"HIGH","privilegesRequired":"LOW","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:N/I:H/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","dateUpdated":"2021-03-02T19:45:17.000Z","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa"},"source":{"advisory":"GHSA-j4xj-4qmc-mmmx","discovery":"UNKNOWN"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"security-advisories@github.com","ID":"CVE-2021-21258","STATE":"PUBLIC","TITLE":"XSS injection in ajax/kanban"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"glpi","version":{"version_data":[{"version_value":">= 9.5.0, < 9.5.4"}]}}]},"vendor_name":"glpi-project"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"GLPI is an open-source asset and IT management software package that provides ITIL Service Desk features, licenses tracking and software auditing. In GLPI from version 9.5.0 and before version 9.5.4, there is a cross-site scripting injection vulnerability when using ajax/kanban.php. This is fixed in version 9.5.4."}]},"impact":{"cvss":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":6.8,"baseSeverity":"MEDIUM","confidentialityImpact":"NONE","integrityImpact":"HIGH","privilegesRequired":"LOW","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:N/I:H/A:N","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://github.com/glpi-project/glpi/security/advisories/GHSA-j4xj-4qmc-mmmx","refsource":"CONFIRM","url":"https://github.com/glpi-project/glpi/security/advisories/GHSA-j4xj-4qmc-mmmx"},{"name":"https://github.com/glpi-project/glpi/commit/e7802fc051696de1f76108ea8dc3bd4e2c880f15","refsource":"MISC","url":"https://github.com/glpi-project/glpi/commit/e7802fc051696de1f76108ea8dc3bd4e2c880f15"}]},"source":{"advisory":"GHSA-j4xj-4qmc-mmmx","discovery":"UNKNOWN"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/glpi-project/glpi/security/advisories/GHSA-j4xj-4qmc-mmmx","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://github.com/glpi-project/glpi/commit/e7802fc051696de1f76108ea8dc3bd4e2c880f15","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T18:09:14.957Z"}}]}}}