{"id":"CVE-2021-21064","state":"PUBLISHED","title":"Magento UPWARD-php Path traversal vulnerability via UPWARD Connector","description":"Magento UPWARD-php version 1.1.4 (and earlier) is affected by a Path traversal vulnerability in Magento UPWARD Connector version 1.1.2 (and earlier) due to the upload feature. An attacker could potentially exploit this vulnerability to upload a malicious YAML file that can contain instructions which allows reading arbitrary files from the remote server. Access to the admin console is required for successful exploitation.","publishedAt":"2021-02-25T13:22:01.015Z","updatedAt":"2024-09-16T16:12:26.679Z","severity":{"score":4.9,"label":"Medium","version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N","source":"adobe"},"assigner":"adobe","products":["Adobe Magento Commerce"],"affected":[{"vendor":"Adobe","product":"Magento Commerce","versions":[{"version":"unspecified","status":"affected","lessThanOrEqual":"1.1.4","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"None","versionType":"custom"}]}],"references":["https://github.com/magento/upward-php/security","https://github.com/magento/upward-php/security/advisories/GHSA-p4pw-hpjx-5685"],"weaknesses":["CWE-22"],"ingestedAt":"2026-10-29T19:47:59.168Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/21xxx/CVE-2021-21064.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-21064","state":"PUBLISHED","datePublished":"2021-02-25T13:22:01.015Z","dateUpdated":"2024-09-16T16:12:26.679Z","assignerShortName":"adobe","assignerOrgId":"078d4453-3bcd-4900-85e6-15281da43538","dateReserved":"2020-12-18T00:00:00.000Z"},"containers":{"cna":{"title":"Magento UPWARD-php Path traversal vulnerability via UPWARD Connector","descriptions":[{"lang":"en","value":"Magento UPWARD-php version 1.1.4 (and earlier) is affected by a Path traversal vulnerability in Magento UPWARD Connector version 1.1.2 (and earlier) due to the upload feature. An attacker could potentially exploit this vulnerability to upload a malicious YAML file that can contain instructions which allows reading arbitrary files from the remote server. Access to the admin console is required for successful exploitation."}],"affected":[{"vendor":"Adobe","product":"Magento Commerce","versions":[{"version":"unspecified","status":"affected","lessThanOrEqual":"1.1.4","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"None","versionType":"custom"}]}],"references":[{"url":"https://github.com/magento/upward-php/security","tags":["x_refsource_MISC"]},{"url":"https://github.com/magento/upward-php/security/advisories/GHSA-p4pw-hpjx-5685","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_0":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":4.9,"baseSeverity":"MEDIUM","confidentialityImpact":"HIGH","integrityImpact":"NONE","privilegesRequired":"HIGH","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N","version":"3.0"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-22","description":"Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') (CWE-22)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"adobe","dateUpdated":"2021-02-25T13:22:01.000Z","orgId":"078d4453-3bcd-4900-85e6-15281da43538"},"datePublic":"2021-02-22T00:00:00.000Z","source":{"discovery":"EXTERNAL"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"psirt@adobe.com","DATE_PUBLIC":"2021-02-22T23:00:00.000Z","ID":"CVE-2021-21064","STATE":"PUBLIC","TITLE":"Magento UPWARD-php Path traversal vulnerability via UPWARD Connector"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Magento Commerce","version":{"version_data":[{"version_affected":"<=","version_value":"1.1.4"},{"version_affected":"<=","version_value":"None"},{"version_affected":"<=","version_value":"None"},{"version_affected":"<=","version_value":"None"}]}}]},"vendor_name":"Adobe"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Magento UPWARD-php version 1.1.4 (and earlier) is affected by a Path traversal vulnerability in Magento UPWARD Connector version 1.1.2 (and earlier) due to the upload feature. An attacker could potentially exploit this vulnerability to upload a malicious YAML file that can contain instructions which allows reading arbitrary files from the remote server. Access to the admin console is required for successful exploitation."}]},"impact":{"cvss":{"attackComplexity":"Low","attackVector":"Network","availabilityImpact":"None","baseScore":4.9,"baseSeverity":"Medium","confidentialityImpact":"High","integrityImpact":"None","privilegesRequired":"High","scope":"Unchanged","userInteraction":"None","vectorString":"CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') (CWE-22)"}]}]},"references":{"reference_data":[{"name":"https://github.com/magento/upward-php/security","refsource":"MISC","url":"https://github.com/magento/upward-php/security"},{"name":"https://github.com/magento/upward-php/security/advisories/GHSA-p4pw-hpjx-5685","refsource":"MISC","url":"https://github.com/magento/upward-php/security/advisories/GHSA-p4pw-hpjx-5685"}]},"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/magento/upward-php/security","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://github.com/magento/upward-php/security/advisories/GHSA-p4pw-hpjx-5685","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T18:01:13.315Z"}}]}}}