{"id":"CVE-2020-8923","state":"PUBLISHED","title":"XSS in Dart","description":"An improper HTML sanitization in Dart versions up to and including 2.7.1 and dev versions 2.8.0-dev.16.0, allows an attacker leveraging DOM Clobbering techniques to skip the sanitization and inject custom html/javascript (XSS). Mitigation: update your Dart SDK to 2.7.2, and 2.8.0-dev.17.0 for the dev version. If you cannot update, we recommend you review the way you use the affected APIs, and pay special attention to cases where user-provided data is used to populate DOM nodes. Consider using Element.innerText or Node.text to populate DOM elements.","publishedAt":"2020-03-26T11:31:55.000Z","updatedAt":"2024-08-04T10:12:10.987Z","severity":{"score":5.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N","source":"Google"},"assigner":"Google","products":["Google Dart SDK"],"affected":[{"vendor":"Google","product":"Dart SDK","versions":[{"version":"stable","status":"affected","lessThanOrEqual":"2.7.1","versionType":"custom"},{"version":"dev","status":"affected","lessThanOrEqual":"2.8.0-dev.16.0","versionType":"custom"}]}],"references":["https://github.com/dart-lang/sdk/security/advisories/GHSA-hfq3-v9pv-p627"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:47:44.297Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2020/8xxx/CVE-2020-8923.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2020-8923","state":"PUBLISHED","datePublished":"2020-03-26T11:31:55.000Z","dateUpdated":"2024-08-04T10:12:10.987Z","assignerShortName":"Google","assignerOrgId":"14ed7db2-1595-443d-9d34-6215bf890778","dateReserved":"2020-02-12T00:00:00.000Z"},"containers":{"cna":{"title":"XSS in Dart","descriptions":[{"lang":"en","value":"An improper HTML sanitization in Dart versions up to and including 2.7.1 and dev versions 2.8.0-dev.16.0, allows an attacker leveraging DOM Clobbering techniques to skip the sanitization and inject custom html/javascript (XSS). Mitigation: update your Dart SDK to 2.7.2, and 2.8.0-dev.17.0 for the dev version. If you cannot update, we recommend you review the way you use the affected APIs, and pay special attention to cases where user-provided data is used to populate DOM nodes. Consider using Element.innerText or Node.text to populate DOM elements."}],"affected":[{"vendor":"Google","product":"Dart SDK","versions":[{"version":"stable","status":"affected","lessThanOrEqual":"2.7.1","versionType":"custom"},{"version":"dev","status":"affected","lessThanOrEqual":"2.8.0-dev.16.0","versionType":"custom"}]}],"references":[{"url":"https://github.com/dart-lang/sdk/security/advisories/GHSA-hfq3-v9pv-p627","tags":["x_refsource_CONFIRM"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":5.4,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Google","dateUpdated":"2020-03-26T11:31:55.000Z","orgId":"14ed7db2-1595-443d-9d34-6215bf890778"},"credits":[{"lang":"en","value":"Vincenzo di Cicco"}],"source":{"discovery":"EXTERNAL"},"x_generator":{"engine":"Vulnogram 0.0.9"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"security@google.com","ID":"CVE-2020-8923","STATE":"PUBLIC","TITLE":"XSS in Dart"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Dart SDK","version":{"version_data":[{"version_affected":"<=","version_name":"stable","version_value":"2.7.1"},{"version_affected":"<=","version_name":"dev","version_value":"2.8.0-dev.16.0"}]}}]},"vendor_name":"Google"}]}},"credit":[{"lang":"eng","value":"Vincenzo di Cicco"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"An improper HTML sanitization in Dart versions up to and including 2.7.1 and dev versions 2.8.0-dev.16.0, allows an attacker leveraging DOM Clobbering techniques to skip the sanitization and inject custom html/javascript (XSS). Mitigation: update your Dart SDK to 2.7.2, and 2.8.0-dev.17.0 for the dev version. If you cannot update, we recommend you review the way you use the affected APIs, and pay special attention to cases where user-provided data is used to populate DOM nodes. Consider using Element.innerText or Node.text to populate DOM elements."}]},"generator":{"engine":"Vulnogram 0.0.9"},"impact":{"cvss":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":5.4,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://github.com/dart-lang/sdk/security/advisories/GHSA-hfq3-v9pv-p627","refsource":"CONFIRM","url":"https://github.com/dart-lang/sdk/security/advisories/GHSA-hfq3-v9pv-p627"}]},"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/dart-lang/sdk/security/advisories/GHSA-hfq3-v9pv-p627","tags":["x_refsource_CONFIRM","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-04T10:12:10.987Z"}}]}}}