{"id":"CVE-2020-8135","state":"PUBLISHED","title":"The uppy npm package < 1.9.3 is vulnerable to a Server-Side Request Forgery (SSRF) vulnerability, which allows an attacker to scan local or external network or otherwise interact w","description":"The uppy npm package < 1.9.3 is vulnerable to a Server-Side Request Forgery (SSRF) vulnerability, which allows an attacker to scan local or external network or otherwise interact with internal systems.","publishedAt":"2020-03-20T18:26:32.000Z","updatedAt":"2024-08-04T09:48:25.652Z","severity":null,"assigner":"hackerone","products":["n/a uppy"],"affected":[{"vendor":"n/a","product":"uppy","versions":[{"version":"Fixed Version: 1.9.3","status":"affected"}]}],"references":["https://hackerone.com/reports/786956"],"weaknesses":["CWE-918"],"ingestedAt":"2026-10-29T19:47:44.297Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2020/8xxx/CVE-2020-8135.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2020-8135","state":"PUBLISHED","datePublished":"2020-03-20T18:26:32.000Z","dateUpdated":"2024-08-04T09:48:25.652Z","assignerShortName":"hackerone","assignerOrgId":"36234546-b8fa-4601-9d6f-f4e334aa8ea1","dateReserved":"2020-01-28T00:00:00.000Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"The uppy npm package < 1.9.3 is vulnerable to a Server-Side Request Forgery (SSRF) vulnerability, which allows an attacker to scan local or external network or otherwise interact with internal systems."}],"affected":[{"vendor":"n/a","product":"uppy","versions":[{"version":"Fixed Version: 1.9.3","status":"affected"}]}],"references":[{"url":"https://hackerone.com/reports/786956","tags":["x_refsource_MISC"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-918","description":"Server-Side Request Forgery (SSRF) (CWE-918)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"hackerone","dateUpdated":"2020-03-20T18:26:32.000Z","orgId":"36234546-b8fa-4601-9d6f-f4e334aa8ea1"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"support@hackerone.com","ID":"CVE-2020-8135","STATE":"PUBLIC"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"uppy","version":{"version_data":[{"version_value":"Fixed Version: 1.9.3"}]}}]},"vendor_name":"n/a"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The uppy npm package < 1.9.3 is vulnerable to a Server-Side Request Forgery (SSRF) vulnerability, which allows an attacker to scan local or external network or otherwise interact with internal systems."}]},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"Server-Side Request Forgery (SSRF) (CWE-918)"}]}]},"references":{"reference_data":[{"name":"https://hackerone.com/reports/786956","refsource":"MISC","url":"https://hackerone.com/reports/786956"}]}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://hackerone.com/reports/786956","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-04T09:48:25.652Z"}}]}}}