{"id":"CVE-2020-8124","state":"PUBLISHED","title":"Insufficient validation and sanitization of user input exists in url-parse npm package version 1.4.4 and earlier may allow attacker to bypass security checks.","description":"Insufficient validation and sanitization of user input exists in url-parse npm package version 1.4.4 and earlier may allow attacker to bypass security checks.","publishedAt":"2020-02-04T19:08:56.000Z","updatedAt":"2024-08-04T09:48:25.621Z","severity":null,"assigner":"hackerone","products":["n/a url-parse"],"affected":[{"vendor":"n/a","product":"url-parse","versions":[{"version":"Fixed Version 1.4.5","status":"affected"}]}],"references":["https://hackerone.com/reports/496293"],"weaknesses":["CWE-20"],"ingestedAt":"2026-10-29T19:47:44.297Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2020/8xxx/CVE-2020-8124.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2020-8124","state":"PUBLISHED","datePublished":"2020-02-04T19:08:56.000Z","dateUpdated":"2024-08-04T09:48:25.621Z","assignerShortName":"hackerone","assignerOrgId":"36234546-b8fa-4601-9d6f-f4e334aa8ea1","dateReserved":"2020-01-28T00:00:00.000Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"Insufficient validation and sanitization of user input exists in url-parse npm package version 1.4.4 and earlier may allow attacker to bypass security checks."}],"affected":[{"vendor":"n/a","product":"url-parse","versions":[{"version":"Fixed Version 1.4.5","status":"affected"}]}],"references":[{"url":"https://hackerone.com/reports/496293","tags":["x_refsource_MISC"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-20","description":"Improper Input Validation (CWE-20)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"hackerone","dateUpdated":"2020-02-04T19:08:56.000Z","orgId":"36234546-b8fa-4601-9d6f-f4e334aa8ea1"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"support@hackerone.com","ID":"CVE-2020-8124","STATE":"PUBLIC"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"url-parse","version":{"version_data":[{"version_value":"Fixed Version 1.4.5"}]}}]},"vendor_name":"n/a"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Insufficient validation and sanitization of user input exists in url-parse npm package version 1.4.4 and earlier may allow attacker to bypass security checks."}]},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"Improper Input Validation (CWE-20)"}]}]},"references":{"reference_data":[{"name":"https://hackerone.com/reports/496293","refsource":"MISC","url":"https://hackerone.com/reports/496293"}]}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://hackerone.com/reports/496293","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-04T09:48:25.621Z"}}]}}}