{"id":"CVE-2020-5211","state":"PUBLISHED","title":"NetHack AUTOCOMPLETE configuration file option is subject to a buffer overflow","description":"In NetHack before 3.6.5, an invalid extended command in value for the AUTOCOMPLETE configuration file option can cause a buffer overflow resulting in a crash or remote code execution/privilege escalation. This vulnerability affects systems that have NetHack installed suid/sgid and shared systems that allow users to upload their own configuration files. Users should upgrade to NetHack 3.6.5.","publishedAt":"2020-01-28T17:55:28.000Z","updatedAt":"2024-08-04T08:22:08.819Z","severity":{"score":5,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:L","source":"GitHub_M"},"assigner":"GitHub_M","products":["NetHack NetHack"],"affected":[{"vendor":"NetHack","product":"NetHack","versions":[{"version":"< 3.6.5","status":"affected"}]}],"references":["https://github.com/NetHack/NetHack/security/advisories/GHSA-r788-4jf4-r9f7"],"weaknesses":["CWE-120"],"ingestedAt":"2026-10-29T19:47:35.543Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2020/5xxx/CVE-2020-5211.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2020-5211","state":"PUBLISHED","datePublished":"2020-01-28T17:55:28.000Z","dateUpdated":"2024-08-04T08:22:08.819Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2020-01-02T00:00:00.000Z"},"containers":{"cna":{"title":"NetHack AUTOCOMPLETE configuration file option is subject to a buffer overflow","descriptions":[{"lang":"en","value":"In NetHack before 3.6.5, an invalid extended command in value for the AUTOCOMPLETE configuration file option can cause a buffer overflow resulting in a crash or remote code execution/privilege escalation. This vulnerability affects systems that have NetHack installed suid/sgid and shared systems that allow users to upload their own configuration files. Users should upgrade to NetHack 3.6.5."}],"affected":[{"vendor":"NetHack","product":"NetHack","versions":[{"version":"< 3.6.5","status":"affected"}]}],"references":[{"url":"https://github.com/NetHack/NetHack/security/advisories/GHSA-r788-4jf4-r9f7","tags":["x_refsource_CONFIRM"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"HIGH","attackVector":"LOCAL","availabilityImpact":"LOW","baseScore":5,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"LOW","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:L","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-120","description":"CWE-120 Buffer Overflow","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","dateUpdated":"2020-01-28T17:55:28.000Z","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa"},"source":{"advisory":"GHSA-r788-4jf4-r9f7","discovery":"UNKNOWN"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"security-advisories@github.com","ID":"CVE-2020-5211","STATE":"PUBLIC","TITLE":"NetHack AUTOCOMPLETE configuration file option is subject to a buffer overflow"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"NetHack","version":{"version_data":[{"version_value":"< 3.6.5"}]}}]},"vendor_name":"NetHack"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"In NetHack before 3.6.5, an invalid extended command in value for the AUTOCOMPLETE configuration file option can cause a buffer overflow resulting in a crash or remote code execution/privilege escalation. This vulnerability affects systems that have NetHack installed suid/sgid and shared systems that allow users to upload their own configuration files. Users should upgrade to NetHack 3.6.5."}]},"impact":{"cvss":{"attackComplexity":"HIGH","attackVector":"LOCAL","availabilityImpact":"LOW","baseScore":5,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"LOW","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:L","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-120 Buffer Overflow"}]}]},"references":{"reference_data":[{"name":"https://github.com/NetHack/NetHack/security/advisories/GHSA-r788-4jf4-r9f7","refsource":"CONFIRM","url":"https://github.com/NetHack/NetHack/security/advisories/GHSA-r788-4jf4-r9f7"}]},"source":{"advisory":"GHSA-r788-4jf4-r9f7","discovery":"UNKNOWN"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/NetHack/NetHack/security/advisories/GHSA-r788-4jf4-r9f7","tags":["x_refsource_CONFIRM","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-04T08:22:08.819Z"}}]}}}