{"id":"CVE-2020-25637","state":"PUBLISHED","title":"A double free memory issue was found to occur in the libvirt API, in versions before 6.8.0, responsible for requesting information about network interfaces of a running QEMU domain","description":"A double free memory issue was found to occur in the libvirt API, in versions before 6.8.0, responsible for requesting information about network interfaces of a running QEMU domain. This flaw affects the polkit access control driver. Specifically, clients connecting to the read-write socket with limited ACL permissions could use this flaw to crash the libvirt daemon, resulting in a denial of service, or potentially escalate their privileges on the system. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.","publishedAt":"2020-10-06T00:00:00.000Z","updatedAt":"2024-08-04T15:40:35.483Z","severity":null,"assigner":"redhat","products":["n/a libvirt"],"affected":[{"vendor":"n/a","product":"libvirt","versions":[{"version":"libvirt versions before 6.8.0","status":"affected"}]}],"references":["https://bugzilla.redhat.com/show_bug.cgi?id=1881037","http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00072.html","http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00073.html","https://security.gentoo.org/glsa/202210-06","https://lists.debian.org/debian-lts-announce/2024/04/msg00000.html"],"weaknesses":["CWE-415"],"ingestedAt":"2026-10-29T19:47:05.429Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2020/25xxx/CVE-2020-25637.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2020-25637","state":"PUBLISHED","datePublished":"2020-10-06T00:00:00.000Z","dateUpdated":"2024-08-04T15:40:35.483Z","assignerShortName":"redhat","assignerOrgId":"53f830b8-0a3f-465b-8143-3b8a9948e749","dateReserved":"2020-09-16T00:00:00.000Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"A double free memory issue was found to occur in the libvirt API, in versions before 6.8.0, responsible for requesting information about network interfaces of a running QEMU domain. This flaw affects the polkit access control driver. Specifically, clients connecting to the read-write socket with limited ACL permissions could use this flaw to crash the libvirt daemon, resulting in a denial of service, or potentially escalate their privileges on the system. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability."}],"affected":[{"vendor":"n/a","product":"libvirt","versions":[{"version":"libvirt versions before 6.8.0","status":"affected"}]}],"references":[{"url":"https://bugzilla.redhat.com/show_bug.cgi?id=1881037"},{"url":"http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00072.html","name":"openSUSE-SU-2020:1778","tags":["vendor-advisory"]},{"url":"http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00073.html","name":"openSUSE-SU-2020:1777","tags":["vendor-advisory"]},{"url":"https://security.gentoo.org/glsa/202210-06","name":"GLSA-202210-06","tags":["vendor-advisory"]},{"url":"https://lists.debian.org/debian-lts-announce/2024/04/msg00000.html","name":"[debian-lts-announce] 20240401 [SECURITY] [DLA 3778-1] libvirt security update","tags":["mailing-list"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-415","type":"CWE","lang":"en","description":"CWE-415"}]}],"providerMetadata":{"shortName":"redhat","orgId":"53f830b8-0a3f-465b-8143-3b8a9948e749","dateUpdated":"2024-04-01T13:06:08.401Z"}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://bugzilla.redhat.com/show_bug.cgi?id=1881037","tags":["x_transferred"]},{"url":"http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00072.html","name":"openSUSE-SU-2020:1778","tags":["vendor-advisory","x_transferred"]},{"url":"http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00073.html","name":"openSUSE-SU-2020:1777","tags":["vendor-advisory","x_transferred"]},{"url":"https://security.gentoo.org/glsa/202210-06","name":"GLSA-202210-06","tags":["vendor-advisory","x_transferred"]},{"url":"https://lists.debian.org/debian-lts-announce/2024/04/msg00000.html","name":"[debian-lts-announce] 20240401 [SECURITY] [DLA 3778-1] libvirt security update","tags":["mailing-list","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-04T15:40:35.483Z"}}]}}}