{"id":"CVE-2020-13669","state":"PUBLISHED","title":"Cross-site Scripting (XSS) vulnerability in ckeditor of Drupal Core allows attacker to inject XSS. This issue affects: Drupal Core 8.8.x versions prior to 8.8.10.; 8.9.x versions p","description":"Cross-site Scripting (XSS) vulnerability in ckeditor of Drupal Core allows attacker to inject XSS. This issue affects: Drupal Core 8.8.x versions prior to 8.8.10.; 8.9.x versions prior to 8.9.6; 9.0.x versions prior to 9.0.6.","publishedAt":"2022-02-11T15:25:12.000Z","updatedAt":"2024-08-04T12:25:16.406Z","severity":null,"assigner":"drupal","products":["Drupal Core"],"affected":[{"vendor":"Drupal","product":"Core","versions":[{"version":"8.8.x","status":"affected","lessThan":"8.8.10","versionType":"custom"},{"version":"8.9.x","status":"affected","lessThan":"8.9.6","versionType":"custom"},{"version":"9.0.x","status":"affected","lessThan":"9.0.6","versionType":"custom"}]}],"references":["https://www.drupal.org/sa-core-2020-010"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:46:30.825Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2020/13xxx/CVE-2020-13669.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2020-13669","state":"PUBLISHED","datePublished":"2022-02-11T15:25:12.000Z","dateUpdated":"2024-08-04T12:25:16.406Z","assignerShortName":"drupal","assignerOrgId":"2c85b837-eb8b-40ed-9d74-228c62987387","dateReserved":"2020-05-28T00:00:00.000Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"Cross-site Scripting (XSS) vulnerability in ckeditor of Drupal Core allows attacker to inject XSS. This issue affects: Drupal Core 8.8.x versions prior to 8.8.10.; 8.9.x versions prior to 8.9.6; 9.0.x versions prior to 9.0.6."}],"affected":[{"vendor":"Drupal","product":"Core","versions":[{"version":"8.8.x","status":"affected","lessThan":"8.8.10","versionType":"custom"},{"version":"8.9.x","status":"affected","lessThan":"8.9.6","versionType":"custom"},{"version":"9.0.x","status":"affected","lessThan":"9.0.6","versionType":"custom"}]}],"references":[{"url":"https://www.drupal.org/sa-core-2020-010","tags":["x_refsource_CONFIRM"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"drupal","dateUpdated":"2022-02-11T15:25:12.000Z","orgId":"2c85b837-eb8b-40ed-9d74-228c62987387"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"security@drupal.org","ID":"CVE-2020-13669","STATE":"PUBLIC"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Core","version":{"version_data":[{"version_affected":"<","version_name":"8.8.x","version_value":"8.8.10"},{"version_affected":"<","version_name":"8.9.x","version_value":"8.9.6"},{"version_affected":"<","version_name":"9.0.x","version_value":"9.0.6"}]}}]},"vendor_name":"Drupal"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Cross-site Scripting (XSS) vulnerability in ckeditor of Drupal Core allows attacker to inject XSS. This issue affects: Drupal Core 8.8.x versions prior to 8.8.10.; 8.9.x versions prior to 8.9.6; 9.0.x versions prior to 9.0.6."}]},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://www.drupal.org/sa-core-2020-010","refsource":"CONFIRM","url":"https://www.drupal.org/sa-core-2020-010"}]}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.drupal.org/sa-core-2020-010","tags":["x_refsource_CONFIRM","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-04T12:25:16.406Z"}}]}}}