{"id":"CVE-2019-7951","state":"PUBLISHED","title":"An information leakage vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. A SOAP web service endpoint does not properly en","description":"An information leakage vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. A SOAP web service endpoint does not properly enforce parameters related to access control. This could be abused to leak customer information via crafted SOAP requests.","publishedAt":"2019-08-02T21:36:12.000Z","updatedAt":"2024-08-04T21:02:19.405Z","severity":null,"assigner":"adobe","products":["n/a Magento 2"],"affected":[{"vendor":"n/a","product":"Magento 2","versions":[{"version":"Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2","status":"affected"}]}],"references":["https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-13"],"weaknesses":[],"ingestedAt":"2026-10-29T19:46:09.463Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2019/7xxx/CVE-2019-7951.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2019-7951","state":"PUBLISHED","datePublished":"2019-08-02T21:36:12.000Z","dateUpdated":"2024-08-04T21:02:19.405Z","assignerShortName":"adobe","assignerOrgId":"078d4453-3bcd-4900-85e6-15281da43538","dateReserved":"2019-02-12T00:00:00.000Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"An information leakage vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. A SOAP web service endpoint does not properly enforce parameters related to access control. This could be abused to leak customer information via crafted SOAP requests."}],"affected":[{"vendor":"n/a","product":"Magento 2","versions":[{"version":"Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2","status":"affected"}]}],"references":[{"url":"https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-13","tags":["x_refsource_CONFIRM"]}],"problemTypes":[{"descriptions":[{"description":"Inadequate Input Validation","lang":"en","type":"text"}]}],"providerMetadata":{"shortName":"adobe","dateUpdated":"2019-08-02T21:36:12.000Z","orgId":"078d4453-3bcd-4900-85e6-15281da43538"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"psirt@adobe.com","ID":"CVE-2019-7951","STATE":"PUBLIC"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Magento 2","version":{"version_data":[{"version_value":"Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2"}]}}]},"vendor_name":"n/a"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"An information leakage vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. A SOAP web service endpoint does not properly enforce parameters related to access control. This could be abused to leak customer information via crafted SOAP requests."}]},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"Inadequate Input Validation"}]}]},"references":{"reference_data":[{"name":"https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-13","refsource":"CONFIRM","url":"https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-13"}]}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-13","tags":["x_refsource_CONFIRM","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-04T21:02:19.405Z"}}]}}}