{"id":"CVE-2019-7881","state":"PUBLISHED","title":"A cross-site scripting mitigation bypass exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This could be exploited by an authenticated ","description":"A cross-site scripting mitigation bypass exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This could be exploited by an authenticated user to escalate privileges (admin vs. admin XSS attack).","publishedAt":"2019-08-02T21:20:04.000Z","updatedAt":"2024-08-04T21:02:19.231Z","severity":null,"assigner":"adobe","products":["n/a Magento 2"],"affected":[{"vendor":"n/a","product":"Magento 2","versions":[{"version":"Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2","status":"affected"}]}],"references":["https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-23"],"weaknesses":[],"ingestedAt":"2026-10-29T19:46:09.463Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2019/7xxx/CVE-2019-7881.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2019-7881","state":"PUBLISHED","datePublished":"2019-08-02T21:20:04.000Z","dateUpdated":"2024-08-04T21:02:19.231Z","assignerShortName":"adobe","assignerOrgId":"078d4453-3bcd-4900-85e6-15281da43538","dateReserved":"2019-02-12T00:00:00.000Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"A cross-site scripting mitigation bypass exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This could be exploited by an authenticated user to escalate privileges (admin vs. admin XSS attack)."}],"affected":[{"vendor":"n/a","product":"Magento 2","versions":[{"version":"Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2","status":"affected"}]}],"references":[{"url":"https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-23","tags":["x_refsource_CONFIRM"]}],"problemTypes":[{"descriptions":[{"description":"Cross-Site Scripting","lang":"en","type":"text"}]}],"providerMetadata":{"shortName":"adobe","dateUpdated":"2019-08-02T21:20:04.000Z","orgId":"078d4453-3bcd-4900-85e6-15281da43538"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"psirt@adobe.com","ID":"CVE-2019-7881","STATE":"PUBLIC"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Magento 2","version":{"version_data":[{"version_value":"Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2"}]}}]},"vendor_name":"n/a"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"A cross-site scripting mitigation bypass exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This could be exploited by an authenticated user to escalate privileges (admin vs. admin XSS attack)."}]},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"Cross-Site Scripting"}]}]},"references":{"reference_data":[{"name":"https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-23","refsource":"CONFIRM","url":"https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-23"}]}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-23","tags":["x_refsource_CONFIRM","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-04T21:02:19.231Z"}}]}}}