{"id":"CVE-2019-5953","state":"PUBLISHED","title":"Buffer overflow in GNU Wget 1.20.1 and earlier allows remote attackers to cause a denial-of-service (DoS) or may execute an arbitrary code via unspecified vectors.","description":"Buffer overflow in GNU Wget 1.20.1 and earlier allows remote attackers to cause a denial-of-service (DoS) or may execute an arbitrary code via unspecified vectors.","publishedAt":"2019-05-17T15:25:56.000Z","updatedAt":"2024-08-04T20:09:23.991Z","severity":null,"assigner":"jpcert","products":["The GNU Projec GNU Wget"],"affected":[{"vendor":"The GNU Projec","product":"GNU Wget","versions":[{"version":"1.20.1 and earlier","status":"affected"}]}],"references":["https://www.gnu.org/software/wget/","http://jvn.jp/en/jp/JVN25261088/index.html","https://support.f5.com/csp/article/K14560101","https://security.gentoo.org/glsa/201908-19","https://access.redhat.com/errata/RHSA-2019:2979","https://access.redhat.com/errata/RHSA-2019:3168"],"weaknesses":[],"ingestedAt":"2026-10-29T19:46:04.126Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2019/5xxx/CVE-2019-5953.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2019-5953","state":"PUBLISHED","datePublished":"2019-05-17T15:25:56.000Z","dateUpdated":"2024-08-04T20:09:23.991Z","assignerShortName":"jpcert","assignerOrgId":"ede6fdc4-6654-4307-a26d-3331c018e2ce","dateReserved":"2019-01-10T00:00:00.000Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"Buffer overflow in GNU Wget 1.20.1 and earlier allows remote attackers to cause a denial-of-service (DoS) or may execute an arbitrary code via unspecified vectors."}],"affected":[{"vendor":"The GNU Projec","product":"GNU Wget","versions":[{"version":"1.20.1 and earlier","status":"affected"}]}],"references":[{"url":"https://www.gnu.org/software/wget/","tags":["x_refsource_MISC"]},{"url":"http://jvn.jp/en/jp/JVN25261088/index.html","tags":["x_refsource_MISC"]},{"url":"https://support.f5.com/csp/article/K14560101","tags":["x_refsource_CONFIRM"]},{"url":"https://security.gentoo.org/glsa/201908-19","name":"GLSA-201908-19","tags":["vendor-advisory","x_refsource_GENTOO"]},{"url":"https://access.redhat.com/errata/RHSA-2019:2979","name":"RHSA-2019:2979","tags":["vendor-advisory","x_refsource_REDHAT"]},{"url":"https://access.redhat.com/errata/RHSA-2019:3168","name":"RHSA-2019:3168","tags":["vendor-advisory","x_refsource_REDHAT"]}],"problemTypes":[{"descriptions":[{"description":"Buffer Overflow","lang":"en","type":"text"}]}],"providerMetadata":{"shortName":"jpcert","dateUpdated":"2019-10-24T22:06:32.000Z","orgId":"ede6fdc4-6654-4307-a26d-3331c018e2ce"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"vultures@jpcert.or.jp","ID":"CVE-2019-5953","STATE":"PUBLIC"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"GNU Wget","version":{"version_data":[{"version_value":"1.20.1 and earlier"}]}}]},"vendor_name":"The GNU Projec"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Buffer overflow in GNU Wget 1.20.1 and earlier allows remote attackers to cause a denial-of-service (DoS) or may execute an arbitrary code via unspecified vectors."}]},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"Buffer Overflow"}]}]},"references":{"reference_data":[{"name":"https://www.gnu.org/software/wget/","refsource":"MISC","url":"https://www.gnu.org/software/wget/"},{"name":"http://jvn.jp/en/jp/JVN25261088/index.html","refsource":"MISC","url":"http://jvn.jp/en/jp/JVN25261088/index.html"},{"name":"https://support.f5.com/csp/article/K14560101","refsource":"CONFIRM","url":"https://support.f5.com/csp/article/K14560101"},{"name":"GLSA-201908-19","refsource":"GENTOO","url":"https://security.gentoo.org/glsa/201908-19"},{"name":"RHSA-2019:2979","refsource":"REDHAT","url":"https://access.redhat.com/errata/RHSA-2019:2979"},{"name":"RHSA-2019:3168","refsource":"REDHAT","url":"https://access.redhat.com/errata/RHSA-2019:3168"}]}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.gnu.org/software/wget/","tags":["x_refsource_MISC","x_transferred"]},{"url":"http://jvn.jp/en/jp/JVN25261088/index.html","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://support.f5.com/csp/article/K14560101","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://security.gentoo.org/glsa/201908-19","name":"GLSA-201908-19","tags":["vendor-advisory","x_refsource_GENTOO","x_transferred"]},{"url":"https://access.redhat.com/errata/RHSA-2019:2979","name":"RHSA-2019:2979","tags":["vendor-advisory","x_refsource_REDHAT","x_transferred"]},{"url":"https://access.redhat.com/errata/RHSA-2019:3168","name":"RHSA-2019:3168","tags":["vendor-advisory","x_refsource_REDHAT","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-04T20:09:23.991Z"}}]}}}