{"id":"CVE-2019-17606","state":"PUBLISHED","title":"The Post editor functionality in the hexo-admin plugin versions 2.3.0 and earlier for Node.js is vulnerable to stored XSS via the content of a post.","description":"The Post editor functionality in the hexo-admin plugin versions 2.3.0 and earlier for Node.js is vulnerable to stored XSS via the content of a post.","publishedAt":"2019-10-23T16:18:14.000Z","updatedAt":"2024-08-05T01:47:13.203Z","severity":null,"assigner":"mitre","products":["n/a n/a"],"affected":[{"vendor":"n/a","product":"n/a","versions":[{"version":"n/a","status":"affected"}]}],"references":["https://github.com/jaredly/hexo-admin/commits/master","https://www.npmjs.com/advisories","https://mega.nz/#%218MYnUQzC%21ZCqixrGyHdBhimCmrszSXdFmI2feImhuZZMcnplNBQQ","https://www.npmjs.com/advisories/1211"],"weaknesses":[],"ingestedAt":"2026-10-29T19:45:38.896Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2019/17xxx/CVE-2019-17606.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2019-17606","state":"PUBLISHED","datePublished":"2019-10-23T16:18:14.000Z","dateUpdated":"2024-08-05T01:47:13.203Z","assignerShortName":"mitre","assignerOrgId":"8254265b-2729-46b6-b9e3-3dfca2d5bfca","dateReserved":"2019-10-15T00:00:00.000Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"The Post editor functionality in the hexo-admin plugin versions 2.3.0 and earlier for Node.js is vulnerable to stored XSS via the content of a post."}],"affected":[{"vendor":"n/a","product":"n/a","versions":[{"version":"n/a","status":"affected"}]}],"references":[{"url":"https://github.com/jaredly/hexo-admin/commits/master","tags":["x_refsource_MISC"]},{"url":"https://www.npmjs.com/advisories","tags":["x_refsource_MISC"]},{"url":"https://mega.nz/#%218MYnUQzC%21ZCqixrGyHdBhimCmrszSXdFmI2feImhuZZMcnplNBQQ","tags":["x_refsource_MISC"]},{"url":"https://www.npmjs.com/advisories/1211","tags":["x_refsource_CONFIRM"]}],"problemTypes":[{"descriptions":[{"description":"n/a","lang":"en","type":"text"}]}],"providerMetadata":{"shortName":"mitre","dateUpdated":"2019-10-23T16:18:14.000Z","orgId":"8254265b-2729-46b6-b9e3-3dfca2d5bfca"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"cve@mitre.org","ID":"CVE-2019-17606","STATE":"PUBLIC"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"n/a","version":{"version_data":[{"version_value":"n/a"}]}}]},"vendor_name":"n/a"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The Post editor functionality in the hexo-admin plugin versions 2.3.0 and earlier for Node.js is vulnerable to stored XSS via the content of a post."}]},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"n/a"}]}]},"references":{"reference_data":[{"name":"https://github.com/jaredly/hexo-admin/commits/master","refsource":"MISC","url":"https://github.com/jaredly/hexo-admin/commits/master"},{"name":"https://www.npmjs.com/advisories","refsource":"MISC","url":"https://www.npmjs.com/advisories"},{"name":"https://mega.nz/#!8MYnUQzC!ZCqixrGyHdBhimCmrszSXdFmI2feImhuZZMcnplNBQQ","refsource":"MISC","url":"https://mega.nz/#!8MYnUQzC!ZCqixrGyHdBhimCmrszSXdFmI2feImhuZZMcnplNBQQ"},{"name":"https://www.npmjs.com/advisories/1211","refsource":"CONFIRM","url":"https://www.npmjs.com/advisories/1211"}]}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/jaredly/hexo-admin/commits/master","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://www.npmjs.com/advisories","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://mega.nz/#%218MYnUQzC%21ZCqixrGyHdBhimCmrszSXdFmI2feImhuZZMcnplNBQQ","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://www.npmjs.com/advisories/1211","tags":["x_refsource_CONFIRM","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-05T01:47:13.203Z"}}]}}}