{"id":"CVE-2019-16781","state":"PUBLISHED","title":"Stored cross-site scripting (XSS) in WordPress block editor","description":"In WordPress before 5.3.1, authenticated users with lower privileges (like contributors) can inject JavaScript code in the block editor, which is executed within the dashboard. It can lead to an admin opening the affected post in the editor leading to XSS.","publishedAt":"2019-12-26T17:00:17.000Z","updatedAt":"2024-08-05T01:24:48.284Z","severity":{"score":5.8,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:N","source":"GitHub_M"},"assigner":"GitHub_M","products":["WordPress WordPress"],"affected":[{"vendor":"WordPress","product":"WordPress","versions":[{"version":"< 5.3.1","status":"affected","lessThan":"5.3.1","versionType":"custom"}]}],"references":["https://wpvulndb.com/vulnerabilities/9976","https://wordpress.org/news/2019/12/wordpress-5-3-1-security-and-maintenance-release/","https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-pg4x-64rh-3c9v","https://hackerone.com/reports/731301","https://seclists.org/bugtraq/2020/Jan/8","https://www.debian.org/security/2020/dsa-4599","https://www.debian.org/security/2020/dsa-4677"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:45:36.262Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2019/16xxx/CVE-2019-16781.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2019-16781","state":"PUBLISHED","datePublished":"2019-12-26T17:00:17.000Z","dateUpdated":"2024-08-05T01:24:48.284Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2019-09-24T00:00:00.000Z"},"containers":{"cna":{"title":"Stored cross-site scripting (XSS) in WordPress block editor","descriptions":[{"lang":"en","value":"In WordPress before 5.3.1, authenticated users with lower privileges (like contributors) can inject JavaScript code in the block editor, which is executed within the dashboard. It can lead to an admin opening the affected post in the editor leading to XSS."}],"affected":[{"vendor":"WordPress","product":"WordPress","versions":[{"version":"< 5.3.1","status":"affected","lessThan":"5.3.1","versionType":"custom"}]}],"references":[{"url":"https://wpvulndb.com/vulnerabilities/9976","tags":["x_refsource_MISC"]},{"url":"https://wordpress.org/news/2019/12/wordpress-5-3-1-security-and-maintenance-release/","tags":["x_refsource_MISC"]},{"url":"https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-pg4x-64rh-3c9v","tags":["x_refsource_CONFIRM"]},{"url":"https://hackerone.com/reports/731301","tags":["x_refsource_MISC"]},{"url":"https://seclists.org/bugtraq/2020/Jan/8","name":"20200108 [SECURITY] [DSA 4599-1] wordpress security update","tags":["mailing-list","x_refsource_BUGTRAQ"]},{"url":"https://www.debian.org/security/2020/dsa-4599","name":"DSA-4599","tags":["vendor-advisory","x_refsource_DEBIAN"]},{"url":"https://www.debian.org/security/2020/dsa-4677","name":"DSA-4677","tags":["vendor-advisory","x_refsource_DEBIAN"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"HIGH","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":5.8,"baseSeverity":"MEDIUM","confidentialityImpact":"HIGH","integrityImpact":"NONE","privilegesRequired":"LOW","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","dateUpdated":"2020-05-06T12:06:10.000Z","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa"},"source":{"advisory":"GHSA-pg4x-64rh-3c9v","discovery":"UNKNOWN"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"security-advisories@github.com","ID":"CVE-2019-16781","STATE":"PUBLIC","TITLE":"Stored cross-site scripting (XSS) in WordPress block editor"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"WordPress","version":{"version_data":[{"version_affected":"<","version_name":"< 5.3.1","version_value":"5.3.1"}]}}]},"vendor_name":"WordPress"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"In WordPress before 5.3.1, authenticated users with lower privileges (like contributors) can inject JavaScript code in the block editor, which is executed within the dashboard. It can lead to an admin opening the affected post in the editor leading to XSS."}]},"impact":{"cvss":{"attackComplexity":"HIGH","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":5.8,"baseSeverity":"MEDIUM","confidentialityImpact":"HIGH","integrityImpact":"NONE","privilegesRequired":"LOW","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:N","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://wpvulndb.com/vulnerabilities/9976","refsource":"MISC","url":"https://wpvulndb.com/vulnerabilities/9976"},{"name":"https://wordpress.org/news/2019/12/wordpress-5-3-1-security-and-maintenance-release/","refsource":"MISC","url":"https://wordpress.org/news/2019/12/wordpress-5-3-1-security-and-maintenance-release/"},{"name":"https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-pg4x-64rh-3c9v","refsource":"CONFIRM","url":"https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-pg4x-64rh-3c9v"},{"name":"https://hackerone.com/reports/731301","refsource":"MISC","url":"https://hackerone.com/reports/731301"},{"name":"20200108 [SECURITY] [DSA 4599-1] wordpress security update","refsource":"BUGTRAQ","url":"https://seclists.org/bugtraq/2020/Jan/8"},{"name":"DSA-4599","refsource":"DEBIAN","url":"https://www.debian.org/security/2020/dsa-4599"},{"name":"DSA-4677","refsource":"DEBIAN","url":"https://www.debian.org/security/2020/dsa-4677"}]},"source":{"advisory":"GHSA-pg4x-64rh-3c9v","discovery":"UNKNOWN"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://wpvulndb.com/vulnerabilities/9976","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://wordpress.org/news/2019/12/wordpress-5-3-1-security-and-maintenance-release/","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-pg4x-64rh-3c9v","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://hackerone.com/reports/731301","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://seclists.org/bugtraq/2020/Jan/8","name":"20200108 [SECURITY] [DSA 4599-1] wordpress security update","tags":["mailing-list","x_refsource_BUGTRAQ","x_transferred"]},{"url":"https://www.debian.org/security/2020/dsa-4599","name":"DSA-4599","tags":["vendor-advisory","x_refsource_DEBIAN","x_transferred"]},{"url":"https://www.debian.org/security/2020/dsa-4677","name":"DSA-4677","tags":["vendor-advisory","x_refsource_DEBIAN","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-05T01:24:48.284Z"}}]}}}