{"id":"CVE-2019-16762","state":"PUBLISHED","title":"Validator parsing discrepancy due to string encoding in NPM slpjs","description":"A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the slpjs npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus. Affected users can upgrade to any version >= 0.21.4.","publishedAt":"2019-11-15T23:10:57.000Z","updatedAt":"2024-08-05T01:24:47.227Z","severity":{"score":5.7,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:H","source":"GitHub_M"},"assigner":"GitHub_M","products":["simpleledger slpjs"],"affected":[{"vendor":"simpleledger","product":"slpjs","versions":[{"version":"< 0.21.4","status":"affected","lessThan":"0.21.4","versionType":"custom"}]}],"references":["https://github.com/simpleledger/slpjs/security/advisories/GHSA-425c-ccf3-3jrr","https://github.com/simpleledger/slpjs/commit/ac8809b42e47790a6f0205991b36f2699ed10c84#diff-fe58606994c412ba56a65141a7aa4a62L701"],"weaknesses":["CWE-20"],"ingestedAt":"2026-10-29T19:45:36.262Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2019/16xxx/CVE-2019-16762.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2019-16762","state":"PUBLISHED","datePublished":"2019-11-15T23:10:57.000Z","dateUpdated":"2024-08-05T01:24:47.227Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2019-09-24T00:00:00.000Z"},"containers":{"cna":{"title":"Validator parsing discrepancy due to string encoding in NPM slpjs","descriptions":[{"lang":"en","value":"A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the slpjs npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus. Affected users can upgrade to any version >= 0.21.4."}],"affected":[{"vendor":"simpleledger","product":"slpjs","versions":[{"version":"< 0.21.4","status":"affected","lessThan":"0.21.4","versionType":"custom"}]}],"references":[{"url":"https://github.com/simpleledger/slpjs/security/advisories/GHSA-425c-ccf3-3jrr","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/simpleledger/slpjs/commit/ac8809b42e47790a6f0205991b36f2699ed10c84#diff-fe58606994c412ba56a65141a7aa4a62L701","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"HIGH","attackVector":"NETWORK","availabilityImpact":"HIGH","baseScore":5.7,"baseSeverity":"MEDIUM","confidentialityImpact":"NONE","integrityImpact":"HIGH","privilegesRequired":"HIGH","scope":"UNCHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:H","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-20","description":"CWE-20 Improper Input Validation","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","dateUpdated":"2019-11-15T23:10:57.000Z","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa"},"source":{"advisory":"cve/GHSA-425c-ccf3-3jrr","discovery":"EXTERNAL"},"x_generator":{"engine":"Vulnogram 0.0.9"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"security-advisories@github.com","ID":"CVE-2019-16762","STATE":"PUBLIC","TITLE":"Validator parsing discrepancy due to string encoding in NPM slpjs"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"slpjs","version":{"version_data":[{"version_affected":"<","version_name":"< 0.21.4","version_value":"0.21.4"}]}}]},"vendor_name":"simpleledger"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the slpjs npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus. Affected users can upgrade to any version >= 0.21.4."}]},"generator":{"engine":"Vulnogram 0.0.9"},"impact":{"cvss":{"attackComplexity":"HIGH","attackVector":"NETWORK","availabilityImpact":"HIGH","baseScore":5.7,"baseSeverity":"MEDIUM","confidentialityImpact":"NONE","integrityImpact":"HIGH","privilegesRequired":"HIGH","scope":"UNCHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:H","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-20 Improper Input Validation"}]}]},"references":{"reference_data":[{"name":"https://github.com/simpleledger/slpjs/security/advisories/GHSA-425c-ccf3-3jrr","refsource":"CONFIRM","url":"https://github.com/simpleledger/slpjs/security/advisories/GHSA-425c-ccf3-3jrr"},{"name":"https://github.com/simpleledger/slpjs/commit/ac8809b42e47790a6f0205991b36f2699ed10c84#diff-fe58606994c412ba56a65141a7aa4a62L701","refsource":"MISC","url":"https://github.com/simpleledger/slpjs/commit/ac8809b42e47790a6f0205991b36f2699ed10c84#diff-fe58606994c412ba56a65141a7aa4a62L701"}]},"source":{"advisory":"cve/GHSA-425c-ccf3-3jrr","discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/simpleledger/slpjs/security/advisories/GHSA-425c-ccf3-3jrr","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://github.com/simpleledger/slpjs/commit/ac8809b42e47790a6f0205991b36f2699ed10c84#diff-fe58606994c412ba56a65141a7aa4a62L701","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-05T01:24:47.227Z"}}]}}}