{"id":"CVE-2019-1003008","state":"PUBLISHED","title":"A cross-site request forgery vulnerability exists in Jenkins Warnings Next Generation Plugin 2.1.1 and earlier in src/main/java/io/jenkins/plugins/analysis/warnings/groovy/GroovyPa","description":"A cross-site request forgery vulnerability exists in Jenkins Warnings Next Generation Plugin 2.1.1 and earlier in src/main/java/io/jenkins/plugins/analysis/warnings/groovy/GroovyParser.java that allows attackers to execute arbitrary code via a form validation HTTP endpoint.","publishedAt":"2019-02-06T16:00:00.000Z","updatedAt":"2024-09-17T00:21:22.209Z","severity":null,"assigner":"jenkins","products":["Jenkins project Jenkins Warnings Next Generation Plugin"],"affected":[{"vendor":"Jenkins project","product":"Jenkins Warnings Next Generation Plugin","versions":[{"version":"2.1.1 and earlier","status":"affected"}]}],"references":["https://jenkins.io/security/advisory/2019-01-28/#SECURITY-1295%20%282%29"],"weaknesses":[],"ingestedAt":"2026-10-29T19:45:14.833Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2019/1003xxx/CVE-2019-1003008.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2019-1003008","state":"PUBLISHED","datePublished":"2019-02-06T16:00:00.000Z","dateUpdated":"2024-09-17T00:21:22.209Z","assignerShortName":"jenkins","assignerOrgId":"39769cd5-e6e2-4dc8-927e-97b3aa056f5b","dateReserved":"2019-02-06T00:00:00.000Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"A cross-site request forgery vulnerability exists in Jenkins Warnings Next Generation Plugin 2.1.1 and earlier in src/main/java/io/jenkins/plugins/analysis/warnings/groovy/GroovyParser.java that allows attackers to execute arbitrary code via a form validation HTTP endpoint."}],"affected":[{"vendor":"Jenkins project","product":"Jenkins Warnings Next Generation Plugin","versions":[{"version":"2.1.1 and earlier","status":"affected"}]}],"references":[{"url":"https://jenkins.io/security/advisory/2019-01-28/#SECURITY-1295%20%282%29","tags":["x_refsource_CONFIRM"]}],"providerMetadata":{"shortName":"jenkins","orgId":"39769cd5-e6e2-4dc8-927e-97b3aa056f5b","dateUpdated":"2023-10-24T16:44:39.458Z"},"dateAssigned":"2019-02-06T00:00:00.000Z","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"jenkinsci-cert@googlegroups.com","DATE_ASSIGNED":"2019-02-06T02:59:03.173949","ID":"CVE-2019-1003008","REQUESTER":"ml@beckweb.net","STATE":"PUBLIC"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Jenkins Warnings Next Generation Plugin","version":{"version_data":[{"version_value":"2.1.1 and earlier"}]}}]},"vendor_name":"Jenkins project"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"A cross-site request forgery vulnerability exists in Jenkins Warnings Next Generation Plugin 2.1.1 and earlier in src/main/java/io/jenkins/plugins/analysis/warnings/groovy/GroovyParser.java that allows attackers to execute arbitrary code via a form validation HTTP endpoint."}]},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-352"}]}]},"references":{"reference_data":[{"name":"https://jenkins.io/security/advisory/2019-01-28/#SECURITY-1295%20(2)","refsource":"CONFIRM","url":"https://jenkins.io/security/advisory/2019-01-28/#SECURITY-1295%20(2)"}]}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://jenkins.io/security/advisory/2019-01-28/#SECURITY-1295%20%282%29","tags":["x_refsource_CONFIRM","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-05T03:00:19.283Z"}}]}}}