{"id":"CVE-2018-6512","state":"PUBLISHED","title":"The previous version of Puppet Enterprise 2018.1 is vulnerable to unsafe code execution when upgrading pe-razor-server. Affected releases are Puppet Enterprise: 2018.1.x versions p","description":"The previous version of Puppet Enterprise 2018.1 is vulnerable to unsafe code execution when upgrading pe-razor-server. Affected releases are Puppet Enterprise: 2018.1.x versions prior to 2018.1.1 and razor-server and pe-razor-server prior to 1.9.0.0.","publishedAt":"2018-06-11T20:00:00.000Z","updatedAt":"2024-09-16T20:17:47.278Z","severity":null,"assigner":"puppet","products":["Puppet Puppet Enterprise 2018.1.x prior to 2018.1.1, razor-server and pe-razor-server prior to 1.9.0.0"],"affected":[{"vendor":"Puppet","product":"Puppet Enterprise 2018.1.x prior to 2018.1.1, razor-server and pe-razor-server prior to 1.9.0.0","versions":[{"version":"2018.1.0, prior to 1.9.0.0","status":"affected"}]}],"references":["https://puppet.com/security/cve/CVE-2018-6512"],"weaknesses":[],"ingestedAt":"2026-10-29T19:44:58.277Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2018/6xxx/CVE-2018-6512.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2018-6512","state":"PUBLISHED","datePublished":"2018-06-11T20:00:00.000Z","dateUpdated":"2024-09-16T20:17:47.278Z","assignerShortName":"puppet","assignerOrgId":"ca2a266c-be2f-4d4b-92d0-47b76b1a9c4e","dateReserved":"2018-02-01T00:00:00.000Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"The previous version of Puppet Enterprise 2018.1 is vulnerable to unsafe code execution when upgrading pe-razor-server. Affected releases are Puppet Enterprise: 2018.1.x versions prior to 2018.1.1 and razor-server and pe-razor-server prior to 1.9.0.0."}],"affected":[{"vendor":"Puppet","product":"Puppet Enterprise 2018.1.x prior to 2018.1.1, razor-server and pe-razor-server prior to 1.9.0.0","versions":[{"version":"2018.1.0, prior to 1.9.0.0","status":"affected"}]}],"references":[{"url":"https://puppet.com/security/cve/CVE-2018-6512","tags":["x_refsource_CONFIRM"]}],"problemTypes":[{"descriptions":[{"description":"Insecure Temporary File","lang":"en","type":"text"}]}],"providerMetadata":{"shortName":"puppet","dateUpdated":"2018-06-11T19:57:01.000Z","orgId":"ca2a266c-be2f-4d4b-92d0-47b76b1a9c4e"},"datePublic":"2018-06-11T00:00:00.000Z","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"security@puppet.com","DATE_PUBLIC":"2018-06-11T00:00:00","ID":"CVE-2018-6512","STATE":"PUBLIC"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Puppet Enterprise 2018.1.x prior to 2018.1.1, razor-server and pe-razor-server prior to 1.9.0.0","version":{"version_data":[{"version_value":"2018.1.0, prior to 1.9.0.0"}]}}]},"vendor_name":"Puppet"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The previous version of Puppet Enterprise 2018.1 is vulnerable to unsafe code execution when upgrading pe-razor-server. Affected releases are Puppet Enterprise: 2018.1.x versions prior to 2018.1.1 and razor-server and pe-razor-server prior to 1.9.0.0."}]},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"Insecure Temporary File"}]}]},"references":{"reference_data":[{"name":"https://puppet.com/security/cve/CVE-2018-6512","refsource":"CONFIRM","url":"https://puppet.com/security/cve/CVE-2018-6512"}]}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://puppet.com/security/cve/CVE-2018-6512","tags":["x_refsource_CONFIRM","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-05T06:10:10.070Z"}}]}}}