{"id":"CVE-2018-1000225","state":"PUBLISHED","title":"Cobbler version Verified as present in Cobbler versions 2.6.11+, but code inspection suggests at least 2.0.0+ or possibly even older versions may be vulnerable contains a Cross Sit","description":"Cobbler version Verified as present in Cobbler versions 2.6.11+, but code inspection suggests at least 2.0.0+ or possibly even older versions may be vulnerable contains a Cross Site Scripting (XSS) vulnerability in cobbler-web that can result in Privilege escalation to admin.. This attack appear to be exploitable via \"network connectivity\". Sending unauthenticated JavaScript payload to the Cobbler XMLRPC API (/cobbler_api).","publishedAt":"2018-08-20T20:00:00.000Z","updatedAt":"2024-08-05T12:40:46.680Z","severity":null,"assigner":"mitre","products":["n/a n/a"],"affected":[{"vendor":"n/a","product":"n/a","versions":[{"version":"n/a","status":"affected"}]}],"references":["https://github.com/cobbler/cobbler/issues/1917","https://movermeyer.com/2018-08-02-privilege-escalation-exploits-in-cobblers-api/"],"weaknesses":[],"ingestedAt":"2026-10-29T19:44:06.197Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2018/1000xxx/CVE-2018-1000225.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2018-1000225","state":"PUBLISHED","datePublished":"2018-08-20T20:00:00.000Z","dateUpdated":"2024-08-05T12:40:46.680Z","assignerShortName":"mitre","assignerOrgId":"8254265b-2729-46b6-b9e3-3dfca2d5bfca","dateReserved":"2018-08-02T00:00:00.000Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"Cobbler version Verified as present in Cobbler versions 2.6.11+, but code inspection suggests at least 2.0.0+ or possibly even older versions may be vulnerable contains a Cross Site Scripting (XSS) vulnerability in cobbler-web that can result in Privilege escalation to admin.. This attack appear to be exploitable via \"network connectivity\". Sending unauthenticated JavaScript payload to the Cobbler XMLRPC API (/cobbler_api)."}],"affected":[{"vendor":"n/a","product":"n/a","versions":[{"version":"n/a","status":"affected"}]}],"references":[{"url":"https://github.com/cobbler/cobbler/issues/1917","tags":["x_refsource_CONFIRM"]},{"url":"https://movermeyer.com/2018-08-02-privilege-escalation-exploits-in-cobblers-api/","tags":["x_refsource_MISC"]}],"problemTypes":[{"descriptions":[{"description":"n/a","lang":"en","type":"text"}]}],"providerMetadata":{"shortName":"mitre","dateUpdated":"2018-10-01T12:57:01.000Z","orgId":"8254265b-2729-46b6-b9e3-3dfca2d5bfca"},"dateAssigned":"2018-08-02T00:00:00.000Z","datePublic":"2018-08-02T00:00:00.000Z","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"cve@mitre.org","DATE_ASSIGNED":"2018-08-02T16:41:53.515834","DATE_REQUESTED":"2018-08-02T16:09:44","ID":"CVE-2018-1000225","REQUESTER":"cvereports@movermeyer.com","STATE":"PUBLIC"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"n/a","version":{"version_data":[{"version_value":"n/a"}]}}]},"vendor_name":"n/a"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Cobbler version Verified as present in Cobbler versions 2.6.11+, but code inspection suggests at least 2.0.0+ or possibly even older versions may be vulnerable contains a Cross Site Scripting (XSS) vulnerability in cobbler-web that can result in Privilege escalation to admin.. This attack appear to be exploitable via \"network connectivity\". Sending unauthenticated JavaScript payload to the Cobbler XMLRPC API (/cobbler_api)."}]},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"n/a"}]}]},"references":{"reference_data":[{"name":"https://github.com/cobbler/cobbler/issues/1917","refsource":"CONFIRM","url":"https://github.com/cobbler/cobbler/issues/1917"},{"name":"https://movermeyer.com/2018-08-02-privilege-escalation-exploits-in-cobblers-api/","refsource":"MISC","url":"https://movermeyer.com/2018-08-02-privilege-escalation-exploits-in-cobblers-api/"}]}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/cobbler/cobbler/issues/1917","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://movermeyer.com/2018-08-02-privilege-escalation-exploits-in-cobblers-api/","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-05T12:40:46.680Z"}}]}}}