{"id":"CVE-2017-7546","state":"PUBLISHED","title":"PostgreSQL versions before 9.2.22, 9.3.18, 9.4.13, 9.5.8 and 9.6.4 are vulnerable to incorrect authentication flaw allowing remote attackers to gain access to database accounts wit","description":"PostgreSQL versions before 9.2.22, 9.3.18, 9.4.13, 9.5.8 and 9.6.4 are vulnerable to incorrect authentication flaw allowing remote attackers to gain access to database accounts with an empty password.","publishedAt":"2017-08-16T18:00:00.000Z","updatedAt":"2024-09-16T17:18:53.123Z","severity":null,"assigner":"redhat","products":["PostgreSQL postgresql"],"affected":[{"vendor":"PostgreSQL","product":"postgresql","versions":[{"version":"9.2.x before 9.2.22","status":"affected"},{"version":"9.3.x before 9.3.18","status":"affected"},{"version":"9.4.x before 9.4.13","status":"affected"},{"version":"9.5.x before 9.5.8","status":"affected"},{"version":"9.6.x before 9.6.4","status":"affected"}]}],"references":["https://access.redhat.com/errata/RHSA-2017:2728","http://www.debian.org/security/2017/dsa-3936","https://access.redhat.com/errata/RHSA-2017:2678","https://access.redhat.com/errata/RHSA-2017:2860","http://www.securityfocus.com/bid/100278","http://www.debian.org/security/2017/dsa-3935","http://www.securitytracker.com/id/1039142","https://www.postgresql.org/about/news/1772/","https://security.gentoo.org/glsa/201710-06","https://access.redhat.com/errata/RHSA-2017:2677"],"weaknesses":["CWE-287"],"ingestedAt":"2026-10-29T19:43:54.997Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2017/7xxx/CVE-2017-7546.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2017-7546","state":"PUBLISHED","datePublished":"2017-08-16T18:00:00.000Z","dateUpdated":"2024-09-16T17:18:53.123Z","assignerShortName":"redhat","assignerOrgId":"53f830b8-0a3f-465b-8143-3b8a9948e749","dateReserved":"2017-04-05T00:00:00.000Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"PostgreSQL versions before 9.2.22, 9.3.18, 9.4.13, 9.5.8 and 9.6.4 are vulnerable to incorrect authentication flaw allowing remote attackers to gain access to database accounts with an empty password."}],"affected":[{"vendor":"PostgreSQL","product":"postgresql","versions":[{"version":"9.2.x before 9.2.22","status":"affected"},{"version":"9.3.x before 9.3.18","status":"affected"},{"version":"9.4.x before 9.4.13","status":"affected"},{"version":"9.5.x before 9.5.8","status":"affected"},{"version":"9.6.x before 9.6.4","status":"affected"}]}],"references":[{"url":"https://access.redhat.com/errata/RHSA-2017:2728","name":"RHSA-2017:2728","tags":["vendor-advisory","x_refsource_REDHAT"]},{"url":"http://www.debian.org/security/2017/dsa-3936","name":"DSA-3936","tags":["vendor-advisory","x_refsource_DEBIAN"]},{"url":"https://access.redhat.com/errata/RHSA-2017:2678","name":"RHSA-2017:2678","tags":["vendor-advisory","x_refsource_REDHAT"]},{"url":"https://access.redhat.com/errata/RHSA-2017:2860","name":"RHSA-2017:2860","tags":["vendor-advisory","x_refsource_REDHAT"]},{"url":"http://www.securityfocus.com/bid/100278","name":"100278","tags":["vdb-entry","x_refsource_BID"]},{"url":"http://www.debian.org/security/2017/dsa-3935","name":"DSA-3935","tags":["vendor-advisory","x_refsource_DEBIAN"]},{"url":"http://www.securitytracker.com/id/1039142","name":"1039142","tags":["vdb-entry","x_refsource_SECTRACK"]},{"url":"https://www.postgresql.org/about/news/1772/","tags":["x_refsource_CONFIRM"]},{"url":"https://security.gentoo.org/glsa/201710-06","name":"GLSA-201710-06","tags":["vendor-advisory","x_refsource_GENTOO"]},{"url":"https://access.redhat.com/errata/RHSA-2017:2677","name":"RHSA-2017:2677","tags":["vendor-advisory","x_refsource_REDHAT"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-287","description":"CWE-287","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"redhat","dateUpdated":"2017-12-30T10:57:01.000Z","orgId":"53f830b8-0a3f-465b-8143-3b8a9948e749"},"datePublic":"2017-08-10T00:00:00.000Z","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"secalert@redhat.com","DATE_PUBLIC":"2017-08-10T00:00:00","ID":"CVE-2017-7546","STATE":"PUBLIC"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"postgresql","version":{"version_data":[{"version_value":"9.2.x before 9.2.22"},{"version_value":"9.3.x before 9.3.18"},{"version_value":"9.4.x before 9.4.13"},{"version_value":"9.5.x before 9.5.8"},{"version_value":"9.6.x before 9.6.4"}]}}]},"vendor_name":"PostgreSQL"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"PostgreSQL versions before 9.2.22, 9.3.18, 9.4.13, 9.5.8 and 9.6.4 are vulnerable to incorrect authentication flaw allowing remote attackers to gain access to database accounts with an empty password."}]},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-287"}]}]},"references":{"reference_data":[{"name":"RHSA-2017:2728","refsource":"REDHAT","url":"https://access.redhat.com/errata/RHSA-2017:2728"},{"name":"DSA-3936","refsource":"DEBIAN","url":"http://www.debian.org/security/2017/dsa-3936"},{"name":"RHSA-2017:2678","refsource":"REDHAT","url":"https://access.redhat.com/errata/RHSA-2017:2678"},{"name":"RHSA-2017:2860","refsource":"REDHAT","url":"https://access.redhat.com/errata/RHSA-2017:2860"},{"name":"100278","refsource":"BID","url":"http://www.securityfocus.com/bid/100278"},{"name":"DSA-3935","refsource":"DEBIAN","url":"http://www.debian.org/security/2017/dsa-3935"},{"name":"1039142","refsource":"SECTRACK","url":"http://www.securitytracker.com/id/1039142"},{"name":"https://www.postgresql.org/about/news/1772/","refsource":"CONFIRM","url":"https://www.postgresql.org/about/news/1772/"},{"name":"GLSA-201710-06","refsource":"GENTOO","url":"https://security.gentoo.org/glsa/201710-06"},{"name":"RHSA-2017:2677","refsource":"REDHAT","url":"https://access.redhat.com/errata/RHSA-2017:2677"}]}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://access.redhat.com/errata/RHSA-2017:2728","name":"RHSA-2017:2728","tags":["vendor-advisory","x_refsource_REDHAT","x_transferred"]},{"url":"http://www.debian.org/security/2017/dsa-3936","name":"DSA-3936","tags":["vendor-advisory","x_refsource_DEBIAN","x_transferred"]},{"url":"https://access.redhat.com/errata/RHSA-2017:2678","name":"RHSA-2017:2678","tags":["vendor-advisory","x_refsource_REDHAT","x_transferred"]},{"url":"https://access.redhat.com/errata/RHSA-2017:2860","name":"RHSA-2017:2860","tags":["vendor-advisory","x_refsource_REDHAT","x_transferred"]},{"url":"http://www.securityfocus.com/bid/100278","name":"100278","tags":["vdb-entry","x_refsource_BID","x_transferred"]},{"url":"http://www.debian.org/security/2017/dsa-3935","name":"DSA-3935","tags":["vendor-advisory","x_refsource_DEBIAN","x_transferred"]},{"url":"http://www.securitytracker.com/id/1039142","name":"1039142","tags":["vdb-entry","x_refsource_SECTRACK","x_transferred"]},{"url":"https://www.postgresql.org/about/news/1772/","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://security.gentoo.org/glsa/201710-06","name":"GLSA-201710-06","tags":["vendor-advisory","x_refsource_GENTOO","x_transferred"]},{"url":"https://access.redhat.com/errata/RHSA-2017:2677","name":"RHSA-2017:2677","tags":["vendor-advisory","x_refsource_REDHAT","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-05T16:04:12.029Z"}}]}}}