{"id":"CVE-2017-20251","state":"PUBLISHED","title":"WordPress Insert PHP Plugin < 3.3.1 PHP Code Injection via REST API","description":"WordPress Insert PHP plugin versions before 3.3.1 contain a PHP code injection vulnerability that allows unauthenticated attackers to execute arbitrary PHP code by injecting malicious shortcodes through the WordPress REST API. Attackers can send POST requests to the wp-json/wp/v2/posts endpoint with crafted content containing insert_php shortcodes to include and execute remote PHP files on the server.","publishedAt":"2026-06-09T11:48:39.195Z","updatedAt":"2026-10-29T21:15:00.988Z","severity":{"score":9.3,"label":"Critical","version":"4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","source":"VulnCheck"},"assigner":"VulnCheck","products":["Themeisle Woody Code Snippets"],"affected":[{"vendor":"Themeisle","product":"Woody Code Snippets","versions":[{"version":"0","status":"affected","lessThan":"3.3.1","versionType":"semver"}]}],"references":["https://www.exploit-db.com/exploits/41308","https://fr.wordpress.org/plugins/insert-php/","https://www.vulncheck.com/advisories/wordpress-insert-php-plugin-php-code-injection-via-rest-api"],"weaknesses":["CWE-94"],"ingestedAt":"2026-10-29T23:08:31.977Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2017/20xxx/CVE-2017-20251.json","commit":"dc7676b3f67d6707e4927968546e7e0125ff7ec7","baselineCommit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2017-20251","state":"PUBLISHED","datePublished":"2026-06-09T11:48:39.195Z","dateUpdated":"2026-10-29T21:15:00.988Z","assignerShortName":"VulnCheck","assignerOrgId":"83251b91-4cc7-4094-a5c7-464a1b83ea10","dateReserved":"2026-06-08T11:54:25.459Z"},"containers":{"cna":{"title":"WordPress Insert PHP Plugin < 3.3.1 PHP Code Injection via REST API","descriptions":[{"lang":"en","value":"WordPress Insert PHP plugin versions before 3.3.1 contain a PHP code injection vulnerability that allows unauthenticated attackers to execute arbitrary PHP code by injecting malicious shortcodes through the WordPress REST API. Attackers can send POST requests to the wp-json/wp/v2/posts endpoint with crafted content containing insert_php shortcodes to include and execute remote PHP files on the server."}],"affected":[{"vendor":"Themeisle","product":"Woody Code Snippets","versions":[{"version":"0","status":"affected","lessThan":"3.3.1","versionType":"semver"}]}],"references":[{"url":"https://www.exploit-db.com/exploits/41308","name":"ExploitDB-41308","tags":["exploit"]},{"url":"https://fr.wordpress.org/plugins/insert-php/","name":"Official Product Homepage","tags":["product"]},{"url":"https://www.vulncheck.com/advisories/wordpress-insert-php-plugin-php-code-injection-via-rest-api","name":"VulnCheck Advisory: WordPress Insert PHP Plugin < 3.3.1 PHP Code Injection via REST API","tags":["third-party-advisory"]}],"metrics":[{"cvssV4_0":{"Automatable":"NOT_DEFINED","Recovery":"NOT_DEFINED","Safety":"NOT_DEFINED","attackComplexity":"LOW","attackRequirements":"NONE","attackVector":"NETWORK","baseScore":9.3,"baseSeverity":"CRITICAL","exploitMaturity":"NOT_DEFINED","privilegesRequired":"NONE","providerUrgency":"NOT_DEFINED","subAvailabilityImpact":"NONE","subConfidentialityImpact":"NONE","subIntegrityImpact":"NONE","userInteraction":"NONE","valueDensity":"NOT_DEFINED","vectorString":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0","vulnAvailabilityImpact":"HIGH","vulnConfidentialityImpact":"HIGH","vulnIntegrityImpact":"HIGH","vulnerabilityResponseEffort":"NOT_DEFINED"},"format":"CVSS"},{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"HIGH","baseScore":9.8,"baseSeverity":"CRITICAL","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"format":"CVSS"}],"problemTypes":[{"descriptions":[{"cweId":"CWE-94","lang":"en","description":"Improper Control of Generation of Code ('Code Injection')","type":"CWE"}]}],"providerMetadata":{"shortName":"VulnCheck","orgId":"83251b91-4cc7-4094-a5c7-464a1b83ea10","dateUpdated":"2026-10-29T21:15:00.988Z"},"tags":["unsupported-when-assigned"],"datePublic":"2017-02-09T00:00:00.000Z","cpeApplicability":[{"nodes":[{"operator":"OR","negate":false,"cpeMatch":[{"vulnerable":true,"criteria":"cpe:2.3:a:cm-wp:woody_code_snippets:*:*:*:*:*:wordpress:*:*","versionEndExcluding":"3.3.1"}]}]}],"credits":[{"lang":"en","value":"sucuri.net @sucurisecurity","type":"finder"}],"x_generator":{"engine":"vulncheck"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-06-09T16:13:44.753300Z","id":"CVE-2017-20251","options":[{"Exploitation":"poc"},{"Automatable":"yes"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-06-09T16:13:54.058Z"}}]}}}