{"id":"CVE-2017-16136","state":"PUBLISHED","title":"method-override is a module used by the Express.js framework to let you use HTTP verbs such as PUT or DELETE in places where the client doesn't support it. method-override is vulne","description":"method-override is a module used by the Express.js framework to let you use HTTP verbs such as PUT or DELETE in places where the client doesn't support it. method-override is vulnerable to a regular expression denial of service vulnerability when specially crafted input is passed in to be parsed via the X-HTTP-Method-Override header.","publishedAt":"2018-06-07T02:00:00.000Z","updatedAt":"2024-09-17T03:18:13.960Z","severity":null,"assigner":"hackerone","products":["HackerOne method-override node module"],"affected":[{"vendor":"HackerOne","product":"method-override node module","versions":[{"version":"<= 1.0.2 || > 2.0.0 < 2.3.10","status":"affected"}]}],"references":["https://nodesecurity.io/advisories/538"],"weaknesses":["CWE-400"],"ingestedAt":"2026-10-29T19:43:25.795Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2017/16xxx/CVE-2017-16136.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2017-16136","state":"PUBLISHED","datePublished":"2018-06-07T02:00:00.000Z","dateUpdated":"2024-09-17T03:18:13.960Z","assignerShortName":"hackerone","assignerOrgId":"36234546-b8fa-4601-9d6f-f4e334aa8ea1","dateReserved":"2017-10-29T00:00:00.000Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"method-override is a module used by the Express.js framework to let you use HTTP verbs such as PUT or DELETE in places where the client doesn't support it. method-override is vulnerable to a regular expression denial of service vulnerability when specially crafted input is passed in to be parsed via the X-HTTP-Method-Override header."}],"affected":[{"vendor":"HackerOne","product":"method-override node module","versions":[{"version":"<= 1.0.2 || > 2.0.0 < 2.3.10","status":"affected"}]}],"references":[{"url":"https://nodesecurity.io/advisories/538","tags":["x_refsource_MISC"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-400","description":"Denial of Service (CWE-400)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"hackerone","dateUpdated":"2018-06-07T01:57:01.000Z","orgId":"36234546-b8fa-4601-9d6f-f4e334aa8ea1"},"datePublic":"2018-04-26T00:00:00.000Z","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"support@hackerone.com","DATE_PUBLIC":"2018-04-26T00:00:00","ID":"CVE-2017-16136","STATE":"PUBLIC"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"method-override node module","version":{"version_data":[{"version_value":"<= 1.0.2 || > 2.0.0 < 2.3.10"}]}}]},"vendor_name":"HackerOne"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"method-override is a module used by the Express.js framework to let you use HTTP verbs such as PUT or DELETE in places where the client doesn't support it. method-override is vulnerable to a regular expression denial of service vulnerability when specially crafted input is passed in to be parsed via the X-HTTP-Method-Override header."}]},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"Denial of Service (CWE-400)"}]}]},"references":{"reference_data":[{"name":"https://nodesecurity.io/advisories/538","refsource":"MISC","url":"https://nodesecurity.io/advisories/538"}]}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://nodesecurity.io/advisories/538","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-05T20:13:07.224Z"}}]}}}