{"id":"CVE-2017-1002152","state":"PUBLISHED","title":"Bodhi 2.9.0 and lower is vulnerable to cross-site scripting resulting in code injection caused by incorrect validation of bug titles.","description":"Bodhi 2.9.0 and lower is vulnerable to cross-site scripting resulting in code injection caused by incorrect validation of bug titles.","publishedAt":"2019-01-10T21:00:00.000Z","updatedAt":"2024-09-16T20:27:46.322Z","severity":null,"assigner":"fedora","products":["Fedora Project Infrastructure Bodhi"],"affected":[{"vendor":"Fedora Project Infrastructure","product":"Bodhi","versions":[{"version":"unspecified","status":"affected","lessThanOrEqual":"2.9.0","versionType":"custom"}]}],"references":["https://github.com/fedora-infra/bodhi/issues/1740"],"weaknesses":["CWE-94"],"ingestedAt":"2026-10-29T19:43:07.872Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2017/1002xxx/CVE-2017-1002152.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2017-1002152","state":"PUBLISHED","datePublished":"2019-01-10T21:00:00.000Z","dateUpdated":"2024-09-16T20:27:46.322Z","assignerShortName":"fedora","assignerOrgId":"92fb86c3-55a5-4fb5-9c3f-4757b9e96dc5","dateReserved":"2019-01-10T00:00:00.000Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"Bodhi 2.9.0 and lower is vulnerable to cross-site scripting resulting in code injection caused by incorrect validation of bug titles."}],"affected":[{"vendor":"Fedora Project Infrastructure","product":"Bodhi","versions":[{"version":"unspecified","status":"affected","lessThanOrEqual":"2.9.0","versionType":"custom"}]}],"references":[{"url":"https://github.com/fedora-infra/bodhi/issues/1740","tags":["x_refsource_CONFIRM"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-94","description":"CWE-94","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"fedora","dateUpdated":"2019-01-10T21:00:00.000Z","orgId":"92fb86c3-55a5-4fb5-9c3f-4757b9e96dc5"},"dateAssigned":"2017-08-10T00:00:00.000Z","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"patrick@puiterwijk.org","DATE_ASSIGNED":"2017-08-10T14:30Z","ID":"CVE-2017-1002152","REQUESTER":"patrick@puiterwijk.org","STATE":"PUBLIC","UPDATED":"2017-08-10T14:30Z"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Bodhi","version":{"version_data":[{"version_affected":"<=","version_value":"2.9.0"}]}}]},"vendor_name":"Fedora Project Infrastructure"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Bodhi 2.9.0 and lower is vulnerable to cross-site scripting resulting in code injection caused by incorrect validation of bug titles."}]},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-94"}]}]},"references":{"reference_data":[{"name":"https://github.com/fedora-infra/bodhi/issues/1740","refsource":"CONFIRM","url":"https://github.com/fedora-infra/bodhi/issues/1740"}]}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/fedora-infra/bodhi/issues/1740","tags":["x_refsource_CONFIRM","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-05T22:08:11.510Z"}}]}}}