{"id":"CVE-2017-1000422","state":"PUBLISHED","title":"Gnome gdk-pixbuf 2.36.8 and older is vulnerable to several integer overflow in the gif_get_lzw function resulting in memory corruption and potential code execution","description":"Gnome gdk-pixbuf 2.36.8 and older is vulnerable to several integer overflow in the gif_get_lzw function resulting in memory corruption and potential code execution","publishedAt":"2018-01-02T20:00:00.000Z","updatedAt":"2024-08-05T22:00:41.426Z","severity":null,"assigner":"mitre","products":["n/a n/a"],"affected":[{"vendor":"n/a","product":"n/a","versions":[{"version":"n/a","status":"affected"}]}],"references":["https://bugzilla.gnome.org/show_bug.cgi?id=785973","https://www.debian.org/security/2018/dsa-4088","https://usn.ubuntu.com/3532-1/","https://lists.debian.org/debian-lts-announce/2018/01/msg00007.html","https://security.gentoo.org/glsa/201804-14"],"weaknesses":[],"ingestedAt":"2026-10-29T19:43:03.788Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2017/1000xxx/CVE-2017-1000422.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2017-1000422","state":"PUBLISHED","datePublished":"2018-01-02T20:00:00.000Z","dateUpdated":"2024-08-05T22:00:41.426Z","assignerShortName":"mitre","assignerOrgId":"8254265b-2729-46b6-b9e3-3dfca2d5bfca","dateReserved":"2018-01-02T00:00:00.000Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"Gnome gdk-pixbuf 2.36.8 and older is vulnerable to several integer overflow in the gif_get_lzw function resulting in memory corruption and potential code execution"}],"affected":[{"vendor":"n/a","product":"n/a","versions":[{"version":"n/a","status":"affected"}]}],"references":[{"url":"https://bugzilla.gnome.org/show_bug.cgi?id=785973","tags":["x_refsource_CONFIRM"]},{"url":"https://www.debian.org/security/2018/dsa-4088","name":"DSA-4088","tags":["vendor-advisory","x_refsource_DEBIAN"]},{"url":"https://usn.ubuntu.com/3532-1/","name":"USN-3532-1","tags":["vendor-advisory","x_refsource_UBUNTU"]},{"url":"https://lists.debian.org/debian-lts-announce/2018/01/msg00007.html","name":"[debian-lts-announce] 20180108 [SECURITY] [DLA 1234-1] gdk-pixbuf security update","tags":["mailing-list","x_refsource_MLIST"]},{"url":"https://security.gentoo.org/glsa/201804-14","name":"GLSA-201804-14","tags":["vendor-advisory","x_refsource_GENTOO"]}],"problemTypes":[{"descriptions":[{"description":"n/a","lang":"en","type":"text"}]}],"providerMetadata":{"shortName":"mitre","dateUpdated":"2018-10-21T09:57:02.000Z","orgId":"8254265b-2729-46b6-b9e3-3dfca2d5bfca"},"dateAssigned":"2017-12-29T00:00:00.000Z","datePublic":"2017-08-07T00:00:00.000Z","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"cve@mitre.org","DATE_ASSIGNED":"2017-12-29","ID":"CVE-2017-1000422","REQUESTER":"junxzm@hotmail.com","STATE":"PUBLIC"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"n/a","version":{"version_data":[{"version_value":"n/a"}]}}]},"vendor_name":"n/a"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Gnome gdk-pixbuf 2.36.8 and older is vulnerable to several integer overflow in the gif_get_lzw function resulting in memory corruption and potential code execution"}]},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"n/a"}]}]},"references":{"reference_data":[{"name":"https://bugzilla.gnome.org/show_bug.cgi?id=785973","refsource":"CONFIRM","url":"https://bugzilla.gnome.org/show_bug.cgi?id=785973"},{"name":"DSA-4088","refsource":"DEBIAN","url":"https://www.debian.org/security/2018/dsa-4088"},{"name":"USN-3532-1","refsource":"UBUNTU","url":"https://usn.ubuntu.com/3532-1/"},{"name":"[debian-lts-announce] 20180108 [SECURITY] [DLA 1234-1] gdk-pixbuf security update","refsource":"MLIST","url":"https://lists.debian.org/debian-lts-announce/2018/01/msg00007.html"},{"name":"GLSA-201804-14","refsource":"GENTOO","url":"https://security.gentoo.org/glsa/201804-14"}]}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://bugzilla.gnome.org/show_bug.cgi?id=785973","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://www.debian.org/security/2018/dsa-4088","name":"DSA-4088","tags":["vendor-advisory","x_refsource_DEBIAN","x_transferred"]},{"url":"https://usn.ubuntu.com/3532-1/","name":"USN-3532-1","tags":["vendor-advisory","x_refsource_UBUNTU","x_transferred"]},{"url":"https://lists.debian.org/debian-lts-announce/2018/01/msg00007.html","name":"[debian-lts-announce] 20180108 [SECURITY] [DLA 1234-1] gdk-pixbuf security update","tags":["mailing-list","x_refsource_MLIST","x_transferred"]},{"url":"https://security.gentoo.org/glsa/201804-14","name":"GLSA-201804-14","tags":["vendor-advisory","x_refsource_GENTOO","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-05T22:00:41.426Z"}}]}}}