{"id":"CVE-2016-7070","state":"PUBLISHED","title":"A privilege escalation flaw was found in the Ansible Tower. When Tower before 3.0.3 deploys a PostgreSQL database, it incorrectly configures the trust level of postgres user. An at","description":"A privilege escalation flaw was found in the Ansible Tower. When Tower before 3.0.3 deploys a PostgreSQL database, it incorrectly configures the trust level of postgres user. An attacker could use this vulnerability to gain admin level access to the database.","publishedAt":"2018-09-11T13:00:00.000Z","updatedAt":"2024-08-06T01:50:46.627Z","severity":{"score":8,"label":"High","version":"3.0","vector":"CVSS:3.0/AV:A/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","source":"redhat"},"assigner":"redhat","products":["Red Hat Ansible Tower"],"affected":[{"vendor":"Red Hat","product":"Ansible Tower","versions":[{"version":"3.0.3","status":"affected"}]}],"references":["https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-7070","https://docs.ansible.com/ansible-tower/3.0.3/html/upgrade-migration-guide/release_notes.html"],"weaknesses":["CWE-266"],"ingestedAt":"2026-10-29T19:42:53.149Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2016/7xxx/CVE-2016-7070.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2016-7070","state":"PUBLISHED","datePublished":"2018-09-11T13:00:00.000Z","dateUpdated":"2024-08-06T01:50:46.627Z","assignerShortName":"redhat","assignerOrgId":"53f830b8-0a3f-465b-8143-3b8a9948e749","dateReserved":"2016-08-23T00:00:00.000Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"A privilege escalation flaw was found in the Ansible Tower. When Tower before 3.0.3 deploys a PostgreSQL database, it incorrectly configures the trust level of postgres user. An attacker could use this vulnerability to gain admin level access to the database."}],"affected":[{"vendor":"Red Hat","product":"Ansible Tower","versions":[{"version":"3.0.3","status":"affected"}]}],"references":[{"url":"https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-7070","tags":["x_refsource_CONFIRM"]},{"url":"https://docs.ansible.com/ansible-tower/3.0.3/html/upgrade-migration-guide/release_notes.html","tags":["x_refsource_CONFIRM"]}],"metrics":[{"cvssV3_0":{"attackComplexity":"LOW","attackVector":"ADJACENT_NETWORK","availabilityImpact":"HIGH","baseScore":8,"baseSeverity":"HIGH","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"LOW","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.0/AV:A/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-266","description":"CWE-266","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"redhat","dateUpdated":"2018-09-11T12:57:01.000Z","orgId":"53f830b8-0a3f-465b-8143-3b8a9948e749"},"datePublic":"2016-11-02T00:00:00.000Z","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"secalert@redhat.com","ID":"CVE-2016-7070","STATE":"PUBLIC"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Ansible Tower","version":{"version_data":[{"version_value":"3.0.3"}]}}]},"vendor_name":"Red Hat"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"A privilege escalation flaw was found in the Ansible Tower. When Tower before 3.0.3 deploys a PostgreSQL database, it incorrectly configures the trust level of postgres user. An attacker could use this vulnerability to gain admin level access to the database."}]},"impact":{"cvss":[[{"vectorString":"8.0/CVSS:3.0/AV:A/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"}]]},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-266"}]}]},"references":{"reference_data":[{"name":"https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-7070","refsource":"CONFIRM","url":"https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-7070"},{"name":"https://docs.ansible.com/ansible-tower/3.0.3/html/upgrade-migration-guide/release_notes.html","refsource":"CONFIRM","url":"https://docs.ansible.com/ansible-tower/3.0.3/html/upgrade-migration-guide/release_notes.html"}]}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-7070","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://docs.ansible.com/ansible-tower/3.0.3/html/upgrade-migration-guide/release_notes.html","tags":["x_refsource_CONFIRM","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-06T01:50:46.627Z"}}]}}}