{"id":"CVE-2015-20124","state":"PUBLISHED","title":"Aspose Importer & Exporter WordPress Plugin < 3.0 Path Traversal via aspose_import_export_download.php","description":"Aspose Importer & Exporter plugin for WordPress before 3.0 contains a path traversal vulnerability that allows unauthenticated attackers to download arbitrary files via the unsanitized 'file' parameter. Attackers can send GET requests to aspose_import_export_download.php with traversal sequences like ../../../wp-config.php to read database credentials. Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-20.","publishedAt":"2026-10-20T20:31:24.966Z","updatedAt":"2026-10-21T15:52:13.050Z","severity":{"score":8.7,"label":"High","version":"4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N","source":"VulnCheck"},"assigner":"VulnCheck","products":["Aspose Aspose Importer & Exporter"],"affected":[{"vendor":"Aspose","product":"Aspose Importer & Exporter","defaultStatus":"unaffected","versions":[{"version":"1.0","status":"affected","lessThan":"3.0","versionType":"custom"}]}],"references":["https://packetstorm.news/files/id/131162/","https://github.com/projectdiscovery/nuclei-templates/blob/main/http/vulnerabilities/wordpress/aspose-ie-file-download.yaml","https://wordpress.org/plugins/aspose-importer-exporter/","https://www.vulncheck.com/advisories/aspose-importer-exporter-wordpress-plugin-3.0-path-traversal-via-aspose-import-export-download-php"],"weaknesses":["CWE-22"],"ingestedAt":"2026-10-29T19:42:00.763Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2015/20xxx/CVE-2015-20124.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2015-20124","state":"PUBLISHED","datePublished":"2026-10-20T20:31:24.966Z","dateUpdated":"2026-10-21T15:52:13.050Z","assignerShortName":"VulnCheck","assignerOrgId":"83251b91-4cc7-4094-a5c7-464a1b83ea10","dateReserved":"2026-10-14T20:25:24.125Z"},"containers":{"cna":{"title":"Aspose Importer & Exporter WordPress Plugin < 3.0 Path Traversal via aspose_import_export_download.php","descriptions":[{"lang":"en","value":"Aspose Importer & Exporter plugin for WordPress before 3.0 contains a path traversal vulnerability that allows unauthenticated attackers to download arbitrary files via the unsanitized 'file' parameter. Attackers can send GET requests to aspose_import_export_download.php with traversal sequences like ../../../wp-config.php to read database credentials. Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-20."}],"affected":[{"vendor":"Aspose","product":"Aspose Importer & Exporter","defaultStatus":"unaffected","versions":[{"version":"1.0","status":"affected","lessThan":"3.0","versionType":"custom"}]}],"references":[{"url":"https://packetstorm.news/files/id/131162/","name":"Packet Storm 131162","tags":["exploit"]},{"url":"https://github.com/projectdiscovery/nuclei-templates/blob/main/http/vulnerabilities/wordpress/aspose-ie-file-download.yaml","name":"Nuclei Template","tags":["technical-description"]},{"url":"https://wordpress.org/plugins/aspose-importer-exporter/","tags":["product"],"name":"WordPress Download Page"},{"url":"https://www.vulncheck.com/advisories/aspose-importer-exporter-wordpress-plugin-3.0-path-traversal-via-aspose-import-export-download-php","name":"VulnCheck Advisory: Aspose Importer & Exporter WordPress Plugin < 3.0 Path Traversal via aspose_import_export_download.php","tags":["third-party-advisory"]}],"metrics":[{"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}],"cvssV4_0":{"attackVector":"NETWORK","attackComplexity":"LOW","attackRequirements":"NONE","privilegesRequired":"NONE","userInteraction":"NONE","vulnConfidentialityImpact":"HIGH","subConfidentialityImpact":"NONE","vulnIntegrityImpact":"NONE","subIntegrityImpact":"NONE","vulnAvailabilityImpact":"NONE","subAvailabilityImpact":"NONE","exploitMaturity":"NOT_DEFINED","Safety":"NOT_DEFINED","Automatable":"NOT_DEFINED","Recovery":"NOT_DEFINED","valueDensity":"NOT_DEFINED","vulnerabilityResponseEffort":"NOT_DEFINED","providerUrgency":"NOT_DEFINED","version":"4.0","baseSeverity":"HIGH","baseScore":8.7,"vectorString":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N"}},{"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}],"cvssV3_1":{"attackVector":"NETWORK","attackComplexity":"LOW","privilegesRequired":"NONE","userInteraction":"NONE","scope":"UNCHANGED","confidentialityImpact":"HIGH","integrityImpact":"NONE","availabilityImpact":"NONE","version":"3.1","baseSeverity":"HIGH","baseScore":7.5,"vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-22","lang":"en","description":"Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')","type":"CWE"}]}],"providerMetadata":{"shortName":"VulnCheck","orgId":"83251b91-4cc7-4094-a5c7-464a1b83ea10","dateUpdated":"2026-10-20T20:31:24.966Z"},"datePublic":"2015-03-28T00:00:00.000Z","tags":["x_known-exploited-vulnerability","unsupported-when-assigned"],"credits":[{"lang":"en","value":"Ashiyane Digital Security Team","type":"finder"},{"lang":"en","value":"The Shadowserver Foundation","type":"reporter"}],"source":{"discovery":"UNKNOWN"},"x_generator":{"engine":"vulncheck-kclub"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-10-21T14:41:46.708855Z","id":"CVE-2015-20124","options":[{"Exploitation":"poc"},{"Automatable":"yes"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-10-21T15:52:13.050Z"}}]}}}