{"id":"CVE-2011-1762","state":"PUBLISHED","title":"A flaw exists in Wordpress related to the 'wp-admin/press-this.php 'script improperly checking user permissions when publishing posts. This may allow a user with 'Contributor-level","description":"A flaw exists in Wordpress related to the 'wp-admin/press-this.php 'script improperly checking user permissions when publishing posts. This may allow a user with 'Contributor-level' privileges to post as if they had 'publish_posts' permission.","publishedAt":"2022-04-18T16:20:38.000Z","updatedAt":"2024-08-06T22:37:25.769Z","severity":null,"assigner":"redhat","products":["n/a wordpress"],"affected":[{"vendor":"n/a","product":"wordpress","versions":[{"version":"wordpress before 3.0.6 and 3.1.2","status":"affected"}]}],"references":["https://wordpress.org/support/wordpress-version/version-3-1-2/"],"weaknesses":["CWE-284"],"ingestedAt":"2026-10-29T19:39:55.290Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2011/1xxx/CVE-2011-1762.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2011-1762","state":"PUBLISHED","datePublished":"2022-04-18T16:20:38.000Z","dateUpdated":"2024-08-06T22:37:25.769Z","assignerShortName":"redhat","assignerOrgId":"53f830b8-0a3f-465b-8143-3b8a9948e749","dateReserved":"2011-04-19T00:00:00.000Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"A flaw exists in Wordpress related to the 'wp-admin/press-this.php 'script improperly checking user permissions when publishing posts. This may allow a user with 'Contributor-level' privileges to post as if they had 'publish_posts' permission."}],"affected":[{"vendor":"n/a","product":"wordpress","versions":[{"version":"wordpress before 3.0.6 and 3.1.2","status":"affected"}]}],"references":[{"url":"https://wordpress.org/support/wordpress-version/version-3-1-2/","tags":["x_refsource_MISC"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-284","description":"CWE-284","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"redhat","dateUpdated":"2022-04-18T16:20:38.000Z","orgId":"53f830b8-0a3f-465b-8143-3b8a9948e749"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"secalert@redhat.com","ID":"CVE-2011-1762","STATE":"PUBLIC"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"wordpress","version":{"version_data":[{"version_value":"wordpress before 3.0.6 and 3.1.2"}]}}]},"vendor_name":"n/a"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"A flaw exists in Wordpress related to the 'wp-admin/press-this.php 'script improperly checking user permissions when publishing posts. This may allow a user with 'Contributor-level' privileges to post as if they had 'publish_posts' permission."}]},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-284"}]}]},"references":{"reference_data":[{"name":"https://wordpress.org/support/wordpress-version/version-3-1-2/","refsource":"MISC","url":"https://wordpress.org/support/wordpress-version/version-3-1-2/"}]}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://wordpress.org/support/wordpress-version/version-3-1-2/","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-06T22:37:25.769Z"}}]}}}